WordPress.org

Forums

MesoColumn
404 Error Page cached on front page (14 posts)

  1. vikas1947
    Member
    Posted 1 year ago #

    Whether it is W3 total cache or WP fastest cache or WP super cache, every plug-in cache error page on front page.
    I contacted their plug-in developer and WP fastest cache plug-in developer did lot, but it seems the problem is with theme, not the plug-in.

    Please look to the problem and suggest any solution.

    And also is W3 total is good for mesocolumn, because W3 minify engine creates problem to it.

  2. Richie KS
    Member
    Theme Author

    Posted 1 year ago #

    lots of users also use the theme with cache plugin but they did not encounter this issues.

    is it your cache settings or any config needed to edit?

    check your wp-admin->settings->reading and make sure 'latest posts' is choosen.

  3. vikas1947
    Member
    Posted 1 year ago #

    For sure, I have selected latest post
    see at waystoworld.com

  4. Richie KS
    Member
    Theme Author

    Posted 1 year ago #

    might be the same photon 'jetpack' issue earlier in your thread.
    i think minify in w3tc are not compatible with the theme, some user mention disabling the minify and it works.

  5. vikas1947
    Member
    Posted 1 year ago #

    As I told in first post that W3 total cache minify engine creates problem therefore I did not use minify in W3 (Actually, I did not use W3 regularly due to its many compatibility issues.)

    In WP fastest cache doing minify has no effect (I tested), but when I enable cache (tick mark the enable cache check box) the error starts.

    Same problem is in also W3, Page cache when enabled, 404 error page is cached on front. (W3 minify just disturb the layout of theme, nothing else.)

    Problem checked with both child and main theme.

  6. Richie KS
    Member
    Theme Author

    Posted 1 year ago #

    anyone having the same issue with the plugin @vikas1947 mention? let me know ok

  7. vikas1947
    Member
    Posted 1 year ago #

    Error is consistent with WP fastest Cache and W3 total cache.
    But, Now using WP Super Cache (from 2 days) and seems to be working ok till now. I will notify if any unexpected thing occurs with WP Super cache also.

  8. onredevil
    Member
    Posted 10 months ago #

    I am using WP Super Cache and having issues. I use the MescoColumn theme with child theme. WP 4.0

    My website won't load, can't access parts of my dashboard and have to reload URL's over and over. Sometime it works, sometimes it doesn't. I have tried W3 plugin, and a couple other caching plugins. All the same outcome. I do not get 404, I just get blank screen. Sometimes it will say internal server error 500.

    I have to access my FTP files to delete the plugin in order for the website to operate normally.

  9. Richie KS
    Member
    Theme Author

    Posted 10 months ago #

    pretty sure this is not theme related issue.
    i used the theme in many client based site and use both wp super cache and w3 total cache and didn't have this issues.

    check your server config or memory limit etc..

  10. onredevil
    Member
    Posted 10 months ago #

    I find it hard to believe that it's all the other plugins and not the theme. If it were 1 plugin, I could understand but since it's 3 different plugins, I have nothing to go off of but a theme issue.

    If I check my server config, what exactly would I be looking for? How would the memory limit affect the cache plugin?

  11. Richie KS
    Member
    Theme Author

    Posted 10 months ago #

    since it occur in 3 seperate plugin that manage cache then it might be some issue on how your server or hosting handle cache etc. some step

    1. check wp-config.php if wp_cache set to true
    2. check plugin doc on 'if cache did not work'

    many user also apply cache wp plugin in their site but not often encounter the 404 cache issue.

  12. onredevil
    Member
    Posted 10 months ago #

    1. wp-config.php is set to true.
    2. did not help.

    Like I said. It do not believe it is the plugin. I believe it is your theme. It happens with EVERY cache plugin.

    I do not receive the 404 cache issue. I receive blank pages, nothing loads. This happens EVERY time I use ANY cache plugin.

  13. MxyzptlkFishStix
    Member
    Posted 9 months ago #

    I'd like to use this theme, but I'm having a serious problem with it. I'm using NGiNX's fastcgi_cache. If I use the theme, the WP toolbar is cached if I visit any page as a logged in user before an anonymous visitor. If I change to another theme, caching functions properly.

  14. Richie KS
    Member
    Theme Author

    Posted 9 months ago #

    try disable any minify css o js functions or plugin

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic