Support » Fixing WordPress » 404 error on image upload WP 2.3.3

  • I just upgraded to WP 2.3.3 but every time I try to upload an image I get a 404 error. I tried disabling all plugins and even tried using just the basic Kubrick theme. Still have the same problem.

    My upload.php is CHMOD to 644 as I believe it’s supposed to be.

    I am at an utter loss and any other somewhat similar post on the topic seems to have a different problem than I am having and a non-working solution.

    Is it that the upload.php isn’t recognizing me as being logged in properly or…? Everything else seems to be working fine.

    REALLY wishing I would have stayed on 2.3.2 right about now…

Viewing 3 replies - 1 through 3 (of 3 total)
  • sorry for the self bump but it won’t let me edit…

    if this is helpful to anyone, this is the part of the 404 page that is not the custom message from me. I am on anhost (midphase) if that is helpful also.

    ::website URL::/wp-admin/upload.php?style=inline&tab=upload&post_id=-1203804011&_wpnonce=33a6d45ae4 /celebs/wp-admin/upload.php?style=inline&tab=upload&post_id=-1203804011 403

    Sorry to bump this again, if a mod can change the title it might help. I mistyped and should have put 403 error not 404

    I was able to fix it by modding the .htaccess file in this way (code in bold is what I added–the #Wordpress parts are there so you know where to add it in your .htaccess file):

    #Wordpress Begin
    <Files upload.php>
    SecFilterInheritance Off

    #Wordpress End

    That said, the question must be begged what/why was the code changed to muck up uploads like this? Seems odd.

    I was thinking, if it was 404, has the upload folder been created?

    If it was 403, I’m unsure? Try CHMOD the upload folder to 666.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘404 error on image upload WP 2.3.3’ is closed to new replies.