WordPress.org

Support

Support » Plugins and Hacks » 404 error on First-Use Setup

404 error on First-Use Setup

Viewing 13 replies - 1 through 13 (of 13 total)
  • jayseventwo
    Member

    @jayseventwo

    Just an update – i just did a fresh install of WordPress on a sub-domain and installed this plugin – am still getting the same errors.

    I really want to use this plugin but if it doesn’t work…

    jayseventwo
    Member

    @jayseventwo

    If the developers could come back with a solution, that would be great. I was going to purchase the premium version after testing, but wont bother if it doesn’t work and there is no support.

    jayseventwo
    Member

    @jayseventwo

    Any possibility that the developers might actually reply to this?

    Thanks

    I’m having the same issue – and given the complete lack of response to this problem here or on the useability dynamics forum – I will not be using this plug-in, and especially not paying for any premium version! Already burned 2 hours trying to figure out this issue and I certainly don’t have time to mess with all the other issues people have with this plugin…

    emgwebmaster
    Member

    @emgwebmaster

    Changing any settings completely breaks the sub-domain site on Multisite network. Results in 404 error or “too many redirects” – what’s up with this?

    silentmedia
    Member

    @silentmedia

    Poor developer feedback! 1 Star

    Amber
    Participant

    @syrehn

    I want to chime in here. I just installed this tonight and the error appears to be coming from the plugin trying to save the settings in the Business Process tab/section.

    I reviewed their forum and found 1 topic that was posted last year in regards to the issue. I posted my comments as well.

    I own my server and host sites off it so I went in directly to my apache logs after I got the error from WP-Invoice (upon trying to save from only the Business Process page). The following were my results:

    ModSecurity: Access denied with code 406 (phase 2). Pattern match “long line of code” at REQUEST_HEADERS:Cookie. [file "usr/local/apache/conf/modsec2.user.conf"] [line "98"] [msg "SQL Injection Attack"] [severity "CRITICAL"] [tag "WEB_ATTACK/SQL_INJECTION"] {hostname “www.mywebsite.com”] {uri “/wp-admin/admin.php”]

    It appears my server is stopping the WP Invoice plugin (or I’m assuming the Invoice plugin) while trying to save something that the server is considering a Web SQL Injection Attack. Yay server security!

    I’m waiting for a response on their official website regarding this. Jayseventwo and klynam, since you’re also having the same issue, it could be the same problem. Do you have access to your apache logs right after getting the error?

    Please, update WP-Invoice and let us know if you still have that issue after systematical disabling other plugins, changing theme to WordPress default(TwentyTen, TwentyEleven).

    I am still getting the same issue, I think it is related to mod_security. Maybe the post that saves the settings contains some banned words???

    Plugin Contributor Anton Korotkoff
    WP-Invoice Support

    @anton-korotkoff

    We need to know your mod_security configuration to be able to reproduce your problems.

    althe3rd
    Member

    @althe3rd

    I am also experiencing this same issue, was there ever a solution found?

    althe3rd
    Member

    @althe3rd

    I don’t have access to my apache logs or mod_security due to being on shared hosting. I find it odd that this is the only plugin I have run across with issues simply applying a POST to save settings.

    I have tried all of the options suggested above (turning off all other plugins and changing my theme to twentytwelve). Nothing fixes it.

    Any other suggestions?

    Plugin Contributor Anton Korotkoff
    WP-Invoice Support

    @anton-korotkoff

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘404 error on First-Use Setup’ is closed to new replies.