WordPress.org

Forums

[resolved] 404 error in front page and hosting co is charging 500$ to solve it (25 posts)

  1. LatinZoneMagazine
    Member
    Posted 1 year ago #

    Yes, I read all the answers to most of those who asked before me. However, I'm new to CSS and my hosting co is refusing to help unless I give them $. Simple, Wednesday I found out the theme I was using is no GPL and was advised by a WP moderator to change into a GPL theme. I searched and searched and found a theme which was appealing. Mantra is the name. I installed it and as soon as I changed the background image, problems started. First, when I changed the background image, my sidebars dissappeared, meanwhile, my old posts where not showing. I kept working the theme though because the site design came out so cool. After I finished it, 12 hours later, my old posts started showin g wheter I pressed images in the front page with htref links or I used the menu. However, I went into my control panel and removed those unneccesary themes I had, like twenty thirteen, twenty ten and some filibusteos magazine thingy. After that, I went into my style sheet and added the scripting for the sidebars left and right. They then started showing, on post pages, inside the center, but my problem is, now I can't see my front page at all. I'm lost and the hosting co wants 500$ from me to solve this. $ I do not have since my product is not selling too good. To complete, they say when goin g into the main page and right clicking and lookin g into VIEW SOURCE they see something totally different from what I see. I'll add the code I see and the one they say they see. My site is http://www.latinzonemagazine.com. I went back to the original not GPL theme, hoping it's settings will solve this, but no. It didn't happened. Help please. Any aditional questions I'll answer immediately since I want to solve this.

    What I see:

    <link rel='stylesheet' id='scap.flashblock-css' href='http://www.latinzonemagazine.com/mag/wp-content/plugins/compact-wp-audio-player/css/flashblock.css?ver=3.6.1' type='text/css' media='all' />
    <link rel='stylesheet' id='scap.player-css' href='http://www.latinzonemagazine.com/mag/wp-content/plugins/compact-wp-audio-player/css/player.css?ver=3.6.1' type='text/css' media='all' />
    <link rel='stylesheet' id='jetpack_likes-css' href='http://www.latinzonemagazine.com/mag/wp-content/plugins/jetpack/modules/likes/style.css?ver=2.5' type='text/css' media='all' />
    <link rel='stylesheet' id='dlm-frontend-css' href='http://www.latinzonemagazine.com/mag/wp-content/plugins/download-monitor/assets/css/frontend.css?ver=3.6.1' type='text/css' media='all' />
    <link rel='stylesheet' id='jetpack-widgets-css' href='http://www.latinzonemagazine.com/mag/wp-content/plugins/jetpack/modules/widgets/widgets.css?ver=20121003' type='text/css' media='all' />
    <link rel='stylesheet' id='sharedaddy-css' href='http://www.latinzonemagazine.com/mag/wp-content/plugins/jetpack/modules/sharedaddy/sharing.css?ver=2.5' type='text/css' media='all' />

    What they say they see:

    <link rel="stylesheet" type="text/css" href="//templates/wistie/css/style.css" media="screen" />
    <link rel="stylesheet" type="text/css" href="//templates/wistie/css/dropdown-default.css" media="screen" />

    I have curently Film Plus installed, however this 404 error repeats on evry theme I install. And no, I do not think I have a wistie theme. I do have one lin redirect to another site from weebly and one plugin for videos called slydely

  2. Justin
    Member
    Posted 1 year ago #

    First remove all hardcoded reference links. I can see that the 404 is coming from scripts and style sheets trying to look for resources using "Localhost"

    Never hardcode a link like that.. Use something like

    <?php get_bloginfo('stylesheet_directory');?>/path/styles.css

  3. Justin
    Member
    Posted 1 year ago #

    By the way, you owe me $450 ; )

  4. WPyogi
    Forum Moderator
    Posted 1 year ago #

    First is to deactivate ALL plugins - and switch to an unmodified default theme.

  5. Justin
    Member
    Posted 1 year ago #

    NM I will eat what I just said..... but worth a shot anyways

  6. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Any modification of theme files should be done in a child theme -

    http://codex.wordpress.org/Child_Themes

    And WP Core should NEVER be modified.

  7. Justin
    Member
    Posted 1 year ago #

    Good call..

  8. LatinZoneMagazine
    Member
    Posted 1 year ago #

    Cool, but if it happens with every theme, it should be something else. Justin, where is it hardcored? I do not have a local host but a shared one. Maybe that would fix it! But where do I go? Because it definetly links href per what I see to my site, the hosting co is the on e who says it doesn't. If you see a hardcored text, other than href http://www.latinzonemagazine.com please let me know and tell me where to find it so I could fix it. WP Yogi, I've done as you told me and got in to this big mess and previously I changed to twenty eleven theme hoping it's configuations will solve, I still get the same error. Being a GPL or not GPL theme.

  9. LatinZoneMagazine
    Member
    Posted 1 year ago #

    I didn't used a child theme with Mantra, now the damage is done and I want m site back up. So, installing and activating other themes is not solving it. PLEASE HELP!!! :-) I'm crying!

  10. LatinZoneMagazine
    Member
    Posted 1 year ago #

    So, to make you happy @WPYogi, I did as you told and activated the Twenty Eleven theme, please viti my page so you can see it's the same main page error and all post, menus and categories are there. Just the main page and now the pictures and videos are missing. Only active plugins are firewall and antivirus. Both from WP.

  11. WPyogi
    Forum Moderator
    Posted 1 year ago #

    I don't see a WP installation at all at your domain name

    http://www.latinzonemagazine.com/

  12. LatinZoneMagazine
    Member
    Posted 1 year ago #

    Might had looked when it was updating. I see it when I look for the page

    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width" />
    <title>Page not found | LatinZoneMagazine.com</title>
    <link rel="profile" href="http://gmpg.org/xfn/11" />
    <link rel="stylesheet" type="text/css" media="all" href="http://www.latinzonemagazine.com/mag/wp-content/themes/twentyeleven/style.css" />
    <link rel="pingback" href="http://www.latinzonemagazine.com/mag/xmlrpc.php" />
    <!--[if lt IE 9]>
    <script src="http://www.latinzonemagazine.com/mag/wp-content/themes/twentyeleven/js/html5.js" type="text/javascript"></script>
    <![endif]-->
    <link rel="alternate" type="application/rss+xml" title="LatinZoneMagazine.com » Feed" href="http://www.latinzonemagazine.com/mag/feed" />
    <link rel="alternate" type="application/rss+xml" title="LatinZoneMagazine.com » Comments Feed" href="http://www.latinzonemagazine.com/mag/comments/feed" />
    <link rel='stylesheet' id='scap.flashblock-css'  href='http://www.latinzonemagazine.com/mag/wp-content/plugins/compact-wp-audio-player/css/flashblock.css?ver=3.6.1' type='text/css' media='all' />
    <link rel='stylesheet' id='scap.player-css'  href='http://www.latinzonemagazine.com/mag/wp-content/plugins/compact-wp-audio-player/css/player.css?ver=3.6.1' type='text/css' media='all' />
    <link rel='stylesheet' id='jetpack_likes-css'  href='http://www.latinzonemagazine.com/mag/wp-content/plugins/jetpack/modules/likes/style.css?ver=2.5' type='text/css' media='all' />
    <link rel='stylesheet' id='dlm-frontend-css'  href='http://www.latinzonemagazine.com/mag/wp-content/plugins/download-monitor/assets/css/frontend.css?ver=3.6.1' type='text/css' media='all' />
    <link rel='stylesheet' id='jetpack-widgets-css'  href='http://www.latinzonemagazine.com/mag/wp-content/plugins/jetpack/modules/widgets/widgets.css?ver=20121003' type='text/css' media='all' />
    <link rel='stylesheet' id='sharedaddy-css'  href='http://www.latinzonemagazine.com/mag/wp-content/plugins/jetpack/modules/sharedaddy/sharing.css?ver=2.5' type='text/css' media='all' />
    <script type='text/javascript' src='http://www.latinzonemagazine.com/mag/wp-content/plugins/compact-wp-audio-player/js/soundmanager2-nodebug-jsmin.js?ver=3.6.1'></script>
    <script type='text/javascript' src='http://www.latinzonemagazine.com/mag/wp-includes/js/jquery/jquery.js?ver=1.10.2'></script>
    <script type='text/javascript' src='http://www.latinzonemagazine.com/mag/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.2.1'></script>
    <script type='text/javascript' src='http://www.latinzonemagazine.com/mag/wp-content/plugins/jetpack/_inc/postmessage.js?ver=2.5'></script>
    <script type='text/javascript' src='http://www.latinzonemagazine.com/mag/wp-content/plugins/jetpack/_inc/jquery.inview.js?ver=2.5'></script>
    <script type='text/javascript' src='http://www.latinzonemagazine.com/mag/wp-content/plugins/jetpack/_inc/jquery.jetpack-resize.js?ver=2.5'></script>
    <link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.latinzonemagazine.com/mag/xmlrpc.php?rsd" />
    <link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.latinzonemagazine.com/mag/wp-includes/wlwmanifest.xml" /> 
    
    <style type="text/css" id="custom-background-css">
    body.custom-background { background-color: #e2e2e2; }
    </style>
    <script type="text/javascript">var src="http://www.latinzonemagazine.com/mag/wp-admin/admin-ajax.php?action=wordfence_logHuman&hid=697A1ED9A5E43C082E986D8939C819E9"; if(window.location.protocol == "https:"){ src = src.replace("http:", "https:"); } var wfHTImg = new Image();  wfHTImg.src=src;</script></head>
    
    <body class="error404 custom-background two-column right-sidebar">
    <div id="page" class="hfeed">
    	<header id="branding" role="banner">
    			<hgroup>
    				<h1 id="site-title"><span><a href="http://www.latinzonemagazine.com/mag/" title="LatinZoneMagazine.com" rel="home">LatinZoneMagazine.com</a></span></h1>
    				<h2 id="site-description">Tu Revista de Musica Latina</h2>
    			</hgroup>
    
    						<a href="http://www.latinzonemagazine.com/mag/">
    									<img src="http://www.latinzonemagazine.com/mag/wp-content/themes/twentyeleven/images/headers/shore.jpg" width="1000" height="288" alt="" />
    							</a>
    
    								<form method="get" id="searchform" action="http://www.latinzonemagazine.com/mag/">
    		<label for="s" class="assistive-text">Search</label>
    		<input type="text" class="field" name="s" id="s" placeholder="Search" />
    		<input type="submit" class="submit" name="submit" id="searchsubmit" value="Search" />
    	</form>
    
    			<nav id="access" role="navigation">
    				<h3 class="assistive-text">Main menu</h3>
    								<div class="skip-link"><a href="#content" title="Skip to primary content">Skip to primary content</a></div>
    				<div class="skip-link"><a href="#secondary" title="Skip to secondary content">Skip to secondary content</a></div>
    								<div class="menu">
    <ul><li ><a href="http://www.latinzonemagazine.com/mag/" title="Home">Home</a><li class="page_item page-item-1713"><a href="http://www.latinzonemagazine.com/mag/home-pagina-principal">Home / Pagina Principal</a><li class="page_item page-item-312"><a href="http://www.latinzonemagazine.com/mag/edicion-1-july-2013">Ediciones</a><li class="page_item page-item-1690"><a href="http://www.latinzonemagazine.com/mag/acerca-de-lzm">Acerca de LZM</a></ul>
    </div>
    			</nav><!-- #access -->
    	</header><!-- #branding -->
    
    	<div id="main">
    
    	<div id="primary">
    		<div id="content" role="main">
    
    			<article id="post-0" class="post error404 not-found">
    				<header class="entry-header">
    					<h1 class="entry-title">This is somewhat embarrassing, isn’t it?</h1>
    				</header>
    
    				<div class="entry-content">
    					<p>It seems we can’t find what you’re looking for. Perhaps searching, or one of the links below, can help.</p>
    
    						<form method="get" id="searchform" action="http://www.latinzonemagazine.com/mag/">
    		<label for="s" class="assistive-text">Search</label>
    		<input type="text" class="field" name="s" id="s" placeholder="Search" />
    		<input type="submit" class="submit" name="submit" id="searchsubmit" value="Search" />
    	</form>
    
    							<div class="widget widget_recent_entries">
  13. WPyogi
    Forum Moderator
    Posted 1 year ago #

    This is what I see on your domain name:

    http://img809.imageshack.us/img809/6489/w2j7.png

    Try deactivating ALL plugins using FTP to change the name on the plugins folder to plugins.HOLD

  14. LatinZoneMagazine
    Member
    Posted 1 year ago #

    This is what I see in my domain.
    http://www.latinzonemagazine.com/mag/
    Which browser are you using Yogi? You seem to see the same as the hostin g company while I see something diferent. I use google chrome and explorer.

  15. WPyogi
    Forum Moderator
    Posted 1 year ago #

    So there, yes, I see a WordPress site on twentyeleven. WordPress is evidently installed in a sub-directory called "mag"?

    So once again, please go change the name on the plugins folder.

  16. leejosepho
    Member
    Posted 1 year ago #

    I do not have a local host but a shared one.

    I believe "localhost" means something different there, so that is not an issue.

  17. LatinZoneMagazine
    Member
    Posted 1 year ago #

    What name Yogi?

  18. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Change plugins to plugins.HOLD - you'll need to use FTP to access the files on the server to do so.

    But first, have you checked under Settings > Reading to see what is set for your home page?

    Have you set up and double-checked your menu under Appearance > Menu?

    Have you reset your permalinks (change them to default and then back to what you are using)?

    Have you actually deactivated ALL plugins via the Dashboard?

  19. Andrew
    Forum moderator
    Posted 1 year ago #

    change the name on the plugins folder to plugins.HOLD

    Edit: Hey WPYogi :)

  20. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Also, I've heard that iPage uses server caching - which could be problematic - have you checked with them about that?

    EDIT - off topic Hi Andrew - nice to see you as always :)!

  21. LatinZoneMagazine
    Member
    Posted 1 year ago #

    I called them and they asked me for $ whereareas, I think we are almost resolved. I created a new index.html file with help from someone in Stack overflow. Remolved third parties from my root and I see a static page now. Can you try it?

  22. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Yes, it looks like it's working again - yay!

  23. LatinZoneMagazine
    Member
    Posted 1 year ago #

    Okay!!! Thanks. Now I'll be carefull to use a child theme for any new theme. :-) Thanks Yogi! You rock!

  24. WPyogi
    Forum Moderator
    Posted 1 year ago #

    You're welcome - I'm glad we hung in there. And yes, definitely use a child theme and just post up on a theme-specific forum if you need help. It might not be as fast as you like since we're all volunteers here, but we do try to get to as much as we can.

  25. LatinZoneMagazine
    Member
    Posted 1 year ago #

    I do thank you, if it wasnt for you, I wouldn't have realized I was usin g something bad! And now, between you and the guy in stackoverflow, My site is back up. I'm preparing to avoid more headaches before installing any new theme by making my post categories into pages. That way my only issues should be design related. :-) Have a great night!

Topic Closed

This topic has been closed to new replies.

About this Topic