WordPress.org

Forums

Edit Author Slug
[resolved] 404 error for network child URL's (3 posts)

  1. Olaf Lederer
    Member
    Posted 2 years ago #

    Hi Brandon,

    I'm trying to use your plugin in networkd mode, but it works only for a part:
    My author slug is "customer"

    http://domain.com/customer/customername/ = works fine

    http://domain.com/childsite/customer/anothercustomer/ = 404 error

    I guess there is some problem with the rewrite rules, it works fine without the custom author slug.
    Any idea how to get it working?

    Thanks Olaf

    http://wordpress.org/extend/plugins/edit-author-slug/

  2. Brandon Allen
    Member
    Plugin Author

    Posted 2 years ago #

    This is by design. While the plugin can be activated network-wide, author slug settings are on a per site basis. If you want 'customer' to be the author slug for http://domain.com/childsite/, then you'll need to explicitly set that in childsite's Edit Author Slug settings.

    I guess I should look into making that clearer and/or an option to allow a network-wide change.

  3. Olaf Lederer
    Member
    Posted 2 years ago #

    Thanks Brandon, that makes sense.

    Do you store the value for the author slug in the option table right?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Edit Author Slug
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic