Support » Networking WordPress » 404 Error for Category Permalinks After Upgrade to 3.1

Viewing 14 replies - 1 through 14 (of 14 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Are you using any plugins to mangle permalinks? Because you cannot, by default, use JUST /category-name for your cats.

    Also, IIS or Linux?

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    If you stripped out the /blog AND the /category, then yeah… likely you did mangle something.

    I’m not using any plugins to mangle permalinks. I tried to use them but they didn’t work.

    I was using the remove /blog slug plugin before upgrade to 3.1. I don’t like having /blog in there. But that plugin is not active now. In fact – I am not entirely sure where the /blog slug went. It shows on the permalinks page – as a constant that cannot be edited – but none of the links show it.

    I should also note that adding the /blog slug in manually to the /category permalinks still return a 404.

    I have multisite – with mapped domains – and I have full control of all sites – so removing the /blog slug is not a threat as I see it.

    The problem is that /category/example-category/ returns a 404. I tried using the plugin that removed the /category slug – but that didn’t help either. I saw that the /?category_name=/example-category/ would go to the correct page – at some point during my trials and errors – so when I put ?category_name= into the category slug on the permalinks page – it works – but it’s ugly and I don’t like it. Also – I tried to put just “cat” into the category slug – but it too returned a 404.

    I don’t know if it’s linux or IIS – my host is BlueHost.

    Thanks!

    Another note – it seems this issue has effected all of my sites. Not just this one.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    So if all your permalinks are hosed, and the htaccess file is there… then either a server settings changed (meh, maybe) or the rewrite rules got flushed form the db.

    and if I can find that thread again… gah.

    Go resave the settings on the permalinks page. what happens?

    So I didn’t realize that they had moved the network plugins – so I did have the remove /blog slug plugin activated through the network admin.

    I deactivated this – but I still get the same results – except now – I get the /blog slug in my permalinks. The categories now look like /blog/category/example-category and the result is a 404 page.

    When I set the permalinks to default – to reset – it goes to:
    /?cat=4779 – and I do not get a 404 page – the category is displayed.

    But when I change to custom permalinks – the permalinks for categories points to: /blog/category/ which results in a 404 page.

    Thanks!

    I believe the problem is with 3.1 onward –

    I had no problem with permalinks before upgrading – it was only after the upgrade – so it seems funny that the server settings would change at the same time.

    I found I can eliminate the /blog slug from wp-admin/network/site-settings.php.

    But the category still will only work with the /?category_name=/example-cat permalink.

    Thanks!

    I think I’m having a similar problem. My custom structure is /archive/%postname%/ and I have no category base or tag base. Unfortunately since 3.1 all of my tag and category pages are now re-written to /archive/tag/example-page and /archive/category/example-page.

    Basically they are taking the custom structure as the base now.

    I run my own LAMP server and have changed nothing. No new plugins, no old plugins to consider and nothing else that could explain this besides a WordPress bug.

    I’m heading over to the bug tracker page now to see if this is a known issue. If I find anything I’ll be back.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    I found I can eliminate the /blog slug from wp-admin/network/site-settings.php.

    Yes but NOTE! If you ever go in and re-save your permalinks, it’ll come back!

    I don’t know if it’s linux or IIS – my host is BlueHost.

    Go ask BlueHost please and thank you 😀

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    @memitch, right that means your PRETTY permalinks are not working. If the htaccess file is in place, go hassle your host.

    the /blog part is a separate issue.

    Hi,

    I had same problem, under the permalinks setting next to Category base I entered: blog

    Not sure if it will fix your problem but it helped me.

    Ok forget my first comment, seems like the problem reoccurred when I edited the custom menu.

    I have the same problem in http://br.wwwhatsnew.com

    I am redirecting the *categoria* url to the Search page

    The problem began with the upgrade to 3.1.1

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    diegopolo, please make a new topic all your own 🙂

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘404 Error for Category Permalinks After Upgrade to 3.1’ is closed to new replies.