Support » Plugins and Hacks » [Resolved] 404 Error for Cart and other WooCommerce pages

[Resolved] 404 Error for Cart and other WooCommerce pages

  • I’m using WooCommerce 2.0.3.

    I have a product store set up on my website, http://www.n7hrc.org.

    I can view products and add them to the cart just fine, but I can’t get any of the other WooCommerce pages to show any content. When I visit one, like the cart page, I get a 404 error.

    I went into WP Pages admin and verified that the pages are there. I even added text to the cart page, above the [woocommerce_cart] shortcode.

    When in Pages admin, I can click the page to edit it. But If I try to view the page by clicking on the view link under the page, I still get the 404 error.

    I tried changing my permalink structure; that didn’t make the pages appear.

    This is the same problem for all sub-pages which were generated by WooCommerce. The only page that doesn’t throw a 404 error is the Products/Shop page. All other WooCommerce pages have 404 errors.

    I’m using the theme Canvas 5.1.2 running Framework 5.5.5

    My installed/activated plugin list is:

    Askimet 2.5.7
    All-in-one Event Calendar by Timely 1.9.4-standard
    BAW Login/Logout menu 1.3.2
    bbPress 2.2.4
    bbPress Admin Bar Addition 1.7.1
    bbPress Moderation 1.5
    bbPress Notify 0.2.1
    bbPress Quotes 0.1
    Jetpack by WordPress.com 2.2
    sMember Framework 130221
    WooCommerce 2.0.3
    WooDojo 1.5.2
    WordPress SEO 1.4.2
    WP Category Post List Widget 2.0.3
    WP Super Cache 1.2


Viewing 15 replies - 1 through 15 (of 30 total)
  • By the way, I just tried deactivating all plugins except for WooCommerce, then I re-generated the permalink structure, but that didn’t make any of the pages show correctly. All WooCommerce pages (except the product page) still return 404 errors.

    Since plugins don’t appear to be the problem, I re-enabled all my plugins again as they were earlier today.

    Roy Ho


    Anytime you change a setting, you need to flush your cache. Because of the fact you’re using a caching plugin. Each cache plugin should have there own reset/flush button to do just that. Take a look at the settings.

    So I would go to permalinks and click on save TWICE. Then go to your caching plugin and do a reset.

    Thanks for the advice. I don’t care too much about the caching, so I just deleted the plugin.

    After deleting the plugin, I saved permalinks twice, like you suggested. Since I no longer have a cache plugin, there is nothing to reset.

    Pages still show “404 Page Not Found”.

    Roy Ho


    And what is your permalinks setting on? Also note that some caching plugins have lingering files which even after deleting will have and causes issues…I had this problem when I used W3 total cache…Not sure if this applies to super cache.

    Common Settings: Month and name

    * Category base: [blank]
    * Tag base: [blank]
    * Product category base: product-category
    * Product tag base: product-tag
    * Product attribute base: [blank]

    Product Permalink base:
    * Custom Base: /shop

    (The last one was set by WooCommerce. I had initially set it to “Shop base”)

    Roy Ho


    Ok if in your permalinks you set it to default ( the first option) save twice…let me know what you see then.

    Thanks! That works. When the first option is set to Default, the shopping cart works like I expect.

    If I change it to anything but default, it goes back to not working.

    Leaving it at default is a passable solution, but I’d love to figure out how to use pretty permalinks, if possible.

    Roy Ho


    Yes, I had you test that so I can determine if this issue is a server issue. It would seem so. Check with your host to see if mod_rewrite is enabled.

    I’ll check into that. Thanks for the direction. I’ll post back tomorrow — or whenever I hear back from my webhost.

    My host is Hostgator.com, and they do have mod_rewrite turned on. I can’t access my .htaccess file directly while I’m at work, so I’ll have to see if the rewrite codes are in there after I get home.

    It is worth noting that all the OTHER pretty permalinks worked fine before I went back to default. (That is to say “blog” and “calendar” and such were all pretty URLs and worked fine. In fact n7hrc.org/shop worked fine. It was just everything lower down than /shop/ that had trouble.)

    Aha! It seems that I can use the Month and Name common setting, if I switch the Product Permalink base setting to Default.

    That seems to be working fine now.

    Thanks again for your help.


    Oh. I forgot to mark this as resolved. Now it’s resolved.

    Thanks again.

    It works like this (for me):

    Settings >> Peralinks >> “Common Settings” = Post name

    Settings >> Peralinks >> “Product permalink base’ = Default

    Any other “Product permalink base” option cause the cart 404 error for me. I prefer “Shop base with category”.

    Does anyone have the cure?

    @coen Jacobs

    I have the same issue.

    My settings are now like this:
    Settings >> Permalinks >> Common Settings = Custom Structure (/%category%/%postname%/)
    Settings >> Permalinks >> Product permalink base = Default

    Any other “Product permalink base” than “default” cause the cart 404 error.

    What is even more interesting, while I now have product permalink base set to “default”, my product urls are not “nnn.com/?product=sample-product”, they are “nnn.com/product/sample-product”…

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘[Resolved] 404 Error for Cart and other WooCommerce pages’ is closed to new replies.