Support » Theme: GeneratePress » 404 Error for All Pages Except Home Page

  • I just moved my website from an older GoDaddy hosting system to a new one, and now only the homepage works. All other pages result in a “404 File Not Found” error. I have absolutely no idea how to fix this….I followed the GoDaddy instructions on how to migrate a website 100% exactly, so don’t even know where this problem is!

    I would appreciate any solutions, especially super easy, non-technical solutions. 🙂 (ie. “Dummy’s version”!)

    Thanks in advance.
    Janine

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Theme Author Tom

    (@edge22)

    Hi there,

    Hard to know what’s happening exactly, but try going to “Settings > Permalinks” and clicking the Save button.

    Let me know 🙂

    Hi @jframst,

    This is common issue. You need to just save permalink structure and click on Save Settings buttons.

    It will work perfectly.

    Permalinks didn’t work for me.

    I had the same problem, just saving the permalinks did not work…

    But when I changed the permalinks to standard – then saved it – then changed it back to the custom structure again, it did work!

    Hope this can help someone 🙂

    Leo

    (@leohsiang)

    Thanks for sharing the solution 🙂

    I have tried changing the permalinks with no success.

    Also tried to add in the htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Still no success, even when I create a fresh page it comes back 404????

    Any help will be very appreciated.

    Leo

    (@leohsiang)

    Can you please open a new topic for your question?

    Please also contact your hosting support to see if they can identify any issues first.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.