Support » Fixing WordPress » 404 Error after altering URLs in Options > General

Viewing 5 replies - 1 through 5 (of 5 total)
  • You will need access via FTP or to the database of the site – this details the various ways to change those back:

    http://codex.wordpress.org/Changing_The_Site_URL

    There’s not another way to do it, unfortunately, so hopefully you can get that sorted out with the hosting company.

    Hi WPyogi,

    I feared this was the only way. I saw other questions similar, but thought I’d double check just in case. I have that link now handy.

    Many thanks for your response!
    -Erin

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    It’s not really that bad and I’m a fan of this method myself.

    http://codex.wordpress.org/Changing_The_Site_URL#Edit_functions.php

    Try this:

    1. Using FTP or whatever file management tools your host has provided you with navigate to the shopomaha/wp-content/themes/concise/ directory.
    2. Once there locate and make a backup copy the functions.php file. Keep that copy safe.
    3. Edit that file and put these lines on top so that it looks like this.
      <?php
      update_option('siteurl','http://esthersconsignment.com/shopomaha');
      update_option('home','http://esthersconsignment.com/shopomaha');
    4. Try and visit http://esthersconsignment.com/shopomaha/ and see if that fixes it.

    If that does fix it then put back that original copy of the functions.php file.

    If it doesn’t then let us know.

    Edit: Ha! I just re-read this part.

    From what I understand, I need to gain access via FTP.

    It doesn’t need to be FTP but it does require file level access. The client’s host provider should be able to provide that access.

    Jan,

    Still awaiting login info for the host. Many, many thanks for your helpful information! I am confident that once I can get in, the problem will be solved.

    And maybe I better do a little more research before updating such things in the future… lesson learned.

    Jan,

    I FINALLY gained access to the host. And your code worked like magic! http://esthersconsignment.com is up and running now.

    Thank you to you (and WPyogi) for helping me out.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘404 Error after altering URLs in Options > General’ is closed to new replies.