Support » Plugin: Yoast SEO » 404 Error

  • Resolved William Lake

    (@orsusdigital)


    Hello,

    I’m getting a 404 error on my category pages.

    My Permalink Settings are – /blog/%postname%/

    I have set Yoast SEO -> Category URLs set to “remove”.

    All category pages return a 404 error.

    If I change my permalinks to remove /blog/ then it works just fine. Problem is that my blog is just a part of my overall website and I need to add /blog/ to the urls for the blog posts.

    If I set category URLs to “keep”, then I end up with a URL like this:

    mywebsite.com/blog/category/thisismycategory/posttitle

    I don’t want to include /category/ because it’s weird and doesn’t fit with the structure of the rest of the URLs.

    I want to achieve this:

    mywebsite.com/blog/thisismycategory/

    This is a bit of problem because all my breadcrumbs lead to a 404!

    I did find one answer here from 6 months ago, but the answer was that this is a bug, submit a bug request. Has this bug been addressed yet?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Sorry. I made a mistake:

    If I set my category URLs to “keep”, then my post URL doesn’t include the word “category” but the category URL does include the word category.

    mywebsite.com/blog/this-is-my-post-title

    But the category url will look like this:

    mywebsite.com/blog/category/this-is-my-category/

    How to remove category and stop the 404 errors? Is it it not possible.

    I might have to move away from Yoast if this can’t be fixed.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Removing the category from the category base URL using the Remove the categories prefix option should only remove the category from the category URL and not from the post URL.

    However, if removing the category cause 404 error, can you please try resetting your permalink structure without changing anything and just hit the save button to check whether this resolves the issue?

    Sorry. I’m not being clear. Nothing to do with the post URL, it’s the category URL>

    I want this:

    mywebsite.com/blog/mycategory

    But this gives a 404 error.

    If I keep the category, I get this

    mywebsite.com/blog/category/mycategory

    I don’t want this.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We understand that you want to remove the category from the category URL and when you remove the category using the Yoast SEO plugin, you see 404 error.

    Can you please try resetting your permalink structure without changing anything and just hit the save button to check whether this resolves the issue?

    Hi,

    Yes, I have tried that already. I found another post with the same issue. This was 6 months ago or something. The plugin support guy (which incidentally was you!) said that it was a bug.

    https://wordpress.org/support/topic/404-after-removing-category-base/

    If I remove /blog/ then it works both with or without ‘category’.

    I tried keeping the blog, then removing category in yoast, then resaving the permalinks, but the 404 still comes.

    Thanks

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Can you try and gather as much information for us as possible? Please perform the following:
    1. Check for conflicts.
    2. Check for JavaScript errors with your console.
    If you find any JavaScript errors related to Yoast SEO or if there is a conflict with a plugin or a theme, you can create a new GitHub issue for our developers. Please report the issue to a third party developer as well.
    If you didn’t find any conflicts or errors, we think the issue is specific to your site. We’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium and receive our Premium email support and we can help you further.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘404 Error’ is closed to new replies.