WordPress.org

Forums

ThirstyAffiliates
[resolved] 404 Error (6 posts)

  1. Briana Thomas
    Member
    Posted 10 months ago #

    I set up thirstyaffiliates and have been trying to use it, but whenever I click on an affiliate link, I just get a 404 error. I have done the activate-reactivate-save permalinks route but it does nothing. I have cleared my cache. I have recreated the affiliate link multiple times, but to no avail. Is there *anything* that can be done? Thanks.

    https://wordpress.org/plugins/thirstyaffiliates/

  2. jkohlbach
    Member
    Plugin Author

    Posted 10 months ago #

    Hi Briana,

    Is your .htaccess file writable by the server? If not there will be a note about it on the Settings->Permalinks page.

    Cheers,
    Josh

  3. Briana Thomas
    Member
    Posted 10 months ago #

    Hi Josh. There's no note anywhere on the page.
    Great plugin you've created, btw. I've seen tons of good reviews and it seems like an easy interface to use, even to someone like me who knows next to nothing about coding. My only hiccup is that the link won't go to where I want it to go. When I click on the link in my thirstyaffiliates page on my dashboard, it works; but when I try to access it in the post where I actually linked to it, it comes up with a 404 error.

  4. jkohlbach
    Member
    Plugin Author

    Posted 10 months ago #

    Hi Briana,

    Ok cool, that eliminates the permalinks.

    Did you change any settings after inserting that link on the page?

    If you try re-inserting the link does that fix the issue?

    Some of the settings under ThirstyAffiliates->Settings, like the link prefix and category in link url options, will require you to re-insert the links.

    If you still don't have any joy you can create a new admin user for me to login and have a look, shoot me an email josh at thirstyaffiliates dot com with the details.

    Cheers,
    Josh

  5. udnonstop
    Member
    Posted 10 months ago #

    I have found a quick fix to the 404 error issues.
    Just make sure you include the http:// root in the destination url.I had my issues solved. Hope it helps

  6. jkohlbach
    Member
    Plugin Author

    Posted 10 months ago #

    Resolved Briana's issue privately, destination URLs must be just the URL starting with http:// or https://

    Just thought I'd add that here in case someone stumbles across it.

Reply

You must log in to post.

About this Plugin

  • ThirstyAffiliates
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic