Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support James Osborne

    (@jamesosborne)

    Thanks for opening a support topic. So we can determine more on this please share the following:

    1. Your Site Health information. You can use this form to share privately if preferred.
    2. Was Site Kit working for you previously on the domain name you’re using to setup the plugin, or did you change the domain name at some point?
    3. Do you see any browser console errors on the same screen where you’re redirected to?

    Once we know the above we’ve investigate this further. Let me know if you have any questions with the above.

    Thread Starter mattialeoni

    (@mattialeoni)

    Hi, thanks for the response.
    1. This is my site health: https://imgur.com/a/m5CHSJO
    2. Yes, it was working on the same domain, then I uploaded a new version of the website, with a new theme and different database.
    3. That’s the error in the console:
    GET mysite.it/wp-admin/?action=googlesitekit_proxy_setup&googlesitekit_code=sitekit-eWHGrWq4EEV6c75bTFsaQA&googlesitekit_site_code=4%2F0AX4XfWhnSX9UJ1cciSZug1rreR31Ej3JwuvtnOMX1VG6ESMT2GAK5U77csLOe2sHXmDvZw&googlesitekit_verification_token=693db4b2423c8235&googlesitekit_verification_token_type=FILE&nonce=448ff58869 404 (Not Found)

    Thank you.

    • This reply was modified 1 month, 2 weeks ago by mattialeoni.
    • This reply was modified 1 month, 2 weeks ago by mattialeoni.
    Plugin Support James Osborne

    (@jamesosborne)

    Many thanks for the update. Unfortunately the screenshot you provided displays only your Site Health status, which differs to your Site Health information (Tools > Site Health > info > Copy site info to clipboard). Regardless we may be able to proceed without your Site Health information based on the other information which you kindly provided.

    As you’ve uploaded a different version of your site with a different database can you try to reset the plugin before attempting Site Kit setup once more (Tools > Available Tools > Reset Site Kit)? I would expect this will allow you to proceed. Note however that you will need to reconnect all previously connected services once more. If other users were previously connected they’ll also need to setup the plugin once more.

    Let me know how you get on with the reset, or please ask if you have any questions with the above.

    Thread Starter mattialeoni

    (@mattialeoni)

    Hello, thanks again for the response.

    Unfortunately the reset doesn’t solve the problem.

    This is the site health info:

    
    ### wp-core ###
    
    version: 5.8.1
    site_language: en_GB
    user_language: en_GB
    timezone: +01:00
    permalink: /%category%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 7
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/clients/client14/web37/web/wp
    wordpress_size: 50.42 MB (52868455 bytes)
    uploads_path: /var/www/clients/client14/web37/web/content/uploads
    uploads_size: 60.53 MB (63475094 bytes)
    themes_path: /var/www/clients/client14/web37/web/content/themes
    themes_size: 2.55 MB (2673234 bytes)
    plugins_path: /var/www/clients/client14/web37/web/content/plugins
    plugins_size: 82.98 MB (87006353 bytes)
    database_size: 21.95 MB (23019520 bytes)
    total_size: 218.43 MB (229042656 bytes)
    
    ### wp-active-theme ###
    
    name: White theme (white-timber)
    version: 1.1
    author: Mattia Leoni
    author_website: (undefined)
    parent_theme: none
    theme_features: core-block-patterns, menus, widgets-block-editor, automatic-feed-links, title-tag, post-thumbnails, html5, post-formats, widgets
    theme_path: /var/www/clients/client14/web37/web/content/themes/white-timber
    auto_update: Disabled
    
    ### wp-plugins-active (15) ###
    
    Advanced Custom Fields PRO: version: 5.8.2, author: Elliot Condon (latest version: 5.10.2), Auto-updates disabled
    Contact Form 7: version: 5.5.1, author: Takayuki Miyoshi, Auto-updates disabled
    Contact Form CFDB7: version: 1.2.5.9, author: Arshid, Auto-updates disabled
    Cookie and Consent Solution for the GDPR & ePrivacy: version: 2.5.7, author: iubenda, Auto-updates disabled
    Custom Post Type UI: version: 1.10.0, author: WebDevStudios, Auto-updates disabled
    Disable Gutenberg: version: 2.5.1, author: Jeff Starr, Auto-updates disabled
    Extreme Vc Copy Paster Basic: version: 1.2, author: Amazee, Auto-updates disabled
    Polylang Pro: version: 2.9.1, author: WP SYNTEX (latest version: 3.1.2), Auto-updates disabled
    Redirection for Contact Form 7: version: 2.3.5, author: Query Solutions, Auto-updates disabled
    Redux: author: (undefined), version: 4.1.24, Auto-updates disabled
    Site Kit by Google: version: 1.43.0, author: Google, Auto-updates disabled
    Timber: version: 1.19.0, author: Jared Novack + Upstatement (latest version: 1.19.1), Auto-updates disabled
    WPBakery Page Builder: version: 6.6.0, author: Michael M - WPBakery.com (latest version: 6.7), Auto-updates disabled
    Yoast Duplicate Post: version: 4.1.2, author: Enrico Battocchi & Team Yoast, Auto-updates disabled
    Yoast SEO: version: 17.3, author: Team Yoast (latest version: 17.4), Auto-updates disabled
    
    ### wp-plugins-inactive (1) ###
    
    Maintenance: version: 4.03, author: WebFactory Ltd, Auto-updates disabled
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Not available
    imagemagick_version: Not available
    imagick_version: Not available
    file_uploads: File uploads is turned off
    post_max_size: 8M
    upload_max_filesize: 2M
    max_effective_size: 2 MB
    max_file_uploads: 20
    gd_version: 2.3.0
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: Linux 3.10.0-1160.21.1.el7.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.3.27 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 128M
    admin_memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 2M
    php_post_max_size: 8M
    curl_version: 7.29.0 NSS/3.53.1
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.5.9-MariaDB-log
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/clients/client14/web37/web/content
    WP_PLUGIN_DIR: /var/www/clients/client14/web37/web/content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: undefined
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### google-site-kit ###
    
    version: 1.43.0
    php_version: 7.3.27
    wp_version: 5.8.1
    reference_url: https://www.formatravel.it
    amp_mode: no
    site_status: not-connected
    user_status: not authenticated
    verification_status: not-verified
    connected_user_count: none
    active_modules: site-verification, search-console
    required_scopes: 
    	openid: ⭕
    	https://www.googleapis.com/auth/userinfo.profile: ⭕
    	https://www.googleapis.com/auth/userinfo.email: ⭕
    	https://www.googleapis.com/auth/siteverification: ⭕
    	https://www.googleapis.com/auth/webmasters: ⭕
    capabilities: 
    	googlesitekit_authenticate: ✅
    	googlesitekit_setup: ✅
    	googlesitekit_view_posts_insights: ⭕
    	googlesitekit_view_dashboard: ⭕
    	googlesitekit_view_module_details: ⭕
    	googlesitekit_manage_options: ⭕
    enabled_features: 
    	ga4setup: ⭕
    	ideaHubModule: ⭕
    	serviceSetupV2: ⭕
    	swgModule: ⭕
    	userInput: ⭕
    	unifiedDashboard: ⭕
    search_console_property: none
    
    ### pll_options ###
    
    browser: 1
    rewrite: 1
    hide_default: 1
    force_lang: 1
    redirect_lang: 0
    media_support: 1
    sync: 0
    post_types: post, page, wp_block, attachment, progetti
    taxonomies: category, post_tag, progetti_cat
    domains: 0
    version: 2.9.1
    default_lang: it
    primary: it => 2
    modal_1: it => 2
    previous_version: 2.8.3
    
    ### pll_language_it ###
    
    term_id: 3
    name: Italiano
    slug: it
    term_group: 0
    term_taxonomy_id: 3
    count: 50
    tl_term_id: 4
    tl_term_taxonomy_id: 4
    tl_count: 5
    locale: it_IT
    is_rtl: 0
    w3c: it-IT
    facebook: it_IT
    flag_url: https://www.formatravel.it:443/content/plugins/polylang-pro/vendor/wpsyntex/polylang/flags/it.png
    home_url: https://www.formatravel.it/
    search_url: https://www.formatravel.it/
    mo_id: 27
    page_on_front: 34
    page_for_posts: 29
    flag_code: it
    fallbacks: 0
    
    
    Plugin Support James Osborne

    (@jamesosborne)

    Thanks for sharing and sorry to hear that didn’t work. Before performing checks with your environment lets rule out any plugin or theme related conflicts. With that can you follow the steps below:

    1. Login to your site from a Chrome browser incognito window
    2. Install and activate the Health Check & Troubleshooting plugin.
    3. Navigate to “Plugins > Health Check & Troubleshooting > Troubleshoot”.
    4. From the same screen click on the “Available Plugins” tab at the top right and then click on the “Enable” option next to “Site Kit by Google”
    5. Attempt to setup Site Kit once more

    You can exit troubleshooting mode afterwards.

    If the same occurs please share your current hosting provider. It might also be useful to know whether you have your WordPress files in a /wp directory previously when you had Site Kit working previously, and whether the site was on the same hosting platform.

    Plugin Support Bethany Chobanian Lang

    (@shetheliving)

    @mattialeoni Checking in here – are you still having trouble?

    Thread Starter mattialeoni

    (@mattialeoni)

    Hello,
    sorry if I didn’t answer anymore. We decided to not use Google Site Kit for this project and just embed the analytics codes since, even with the latest suggestion James proposed, it just wouldn’t work.

    Thank you anyway for the support.

    Plugin Support James Osborne

    (@jamesosborne)

    Sorry to hear that. If you decide to give Site Kit another go we’d be happy to look into this further with you. Based on the checks you’ve already performed it could be a configuration at host level impacting setup. Best of luck with your site going forward.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.