Support » Plugin: All in One SEO Pack » 404 due to configuration

  • Resolved coffear

    (@coffear)


    I am currently using the iThemes security plugin along with the SEO plugin.

    1 of the suggestions that the ithemes security plugin suggests is changing the wp-content folders name.

    Unfortunately your plugin is currently causing an issue for this. Instead of using the wordpress config to ascertain the name of the wp-content folder you are hard coding this (located in all_in_one_seo_pack.php)

    if ( ! defined( ‘WP_CONTENT_URL’ ) )
    define( ‘WP_CONTENT_URL’, site_url() . ‘/wp-content’ );
    if ( ! defined( ‘WP_CONTENT_DIR’ ) )
    define( ‘WP_CONTENT_DIR’, ABSPATH . ‘wp-content’ );

    It would be ideal for this to change so that you are not using hard coded folder names.

    As I am using the ithemes security plugin with 404 protection on it is causing me to be banned from my blog periodically.

    https://wordpress.org/plugins/all-in-one-seo-pack/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Peter Baylies

    (@pbaylies)

    Hi coffear,

    Thanks for the tip, I’ll see if we can remove these – if you look further you’ll see that those constants are no longer being used anywhere in the plugin.

    Hmm I will need to look further into the issue. Has wordpress changed how they define these? Is it possible some of the core code looks for these constants prior to checking the DB.

    If that is the case then your code might be hijacking the dir and url settings. (pure conjecture at this point, just thinking aloud).

    The reason I believe that your plugin is causing the issue is due to receiving reports that the following URL is resulting in a 404 (and I have been banned as per my original post as I triggered too many 404’s)

    /wp-content/plugins/all-in-one-seo-pack/images/default-user-image.png

    I don’t particularly want to disable the 404 check especially if the issue can be fixed by correcting some rogue code.

    Hey guys. I have found the cause of the issue. Turns out it was the Default “OG:Image” setting in the social meta page of the plugin configuration.

    I installed this plugin prior to themes. Issue resolved once I updated the path.

    Plugin Contributor Peter Baylies

    (@pbaylies)

    Hi coffear,

    That makes sense if the path got saved previously; All in One SEO Pack uses plugin_dir_url() to determine this path originally, so that should work fine with iThemes security if that change had already been in place.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘404 due to configuration’ is closed to new replies.