Support » Plugin: Custom Post Type Permalinks » 404: /custom_post_type/custom_taxonomy_category/post_name/

  • Setup (via Pods):

    • Custom post type: podcasts (we’ll use episode-1 as an example post slug)
    • Custom taxonomy: podcast_series (we’ll use XYZ as an example category)

    Permalink settings:

    • podcasts format: /podcasts/%podcast_series%/%postname%/
    • In the permalink settings, whenever I select “Use custom permalink of custom taxonomy archive” and save, the page reloads but the box is still unchecked. Based on the description of the option, it sounds like it would do what I want (” If you check this, the custom taxonomy’s permalinks will be /post_type/taxonomy/term”). I just can’t get it to activate.

    For the “podcasts” CPT, the settings are as follows:

    • Enable Archive Page: checked
    • Archive Page Slug Override: podcasts
    • Hierarchical: unchecked
    • Rewrite: checked
    • Custom Rewrite Slug: empty
    • Rewrite with Front: unchecked
    • Rewrite Pages: unchecked

    For the “podcast-series” taxonomy, the settings are as follows:

    • Rewrite: checked
    • Custom Rewrite Slug: podcasts
    • Rewrite with front: unchecked
    • Hierarchical Permalinks: unchecked

    What works:

    • CPT archive: /podcasts/
    • Custom taxonomy archive: /podcasts/XYZ/

    What doesn’t work:

    • Single post: /podcasts/XYZ/episode-1/

    I’ve tried multiple combinations of settings across permalink settings and settings in Pods, either the single post page works and the taxonomy archive doesn’t, or it’s the other way around.

    • This topic was modified 1 year, 4 months ago by besweeet.
    • This topic was modified 1 year, 4 months ago by besweeet.
    • This topic was modified 1 year, 4 months ago by besweeet.
    • This topic was modified 1 year, 4 months ago by besweeet.
Viewing 1 replies (of 1 total)
  • Plugin Author Toro_Unit (Hiroshi Urabe)

    (@toro_unit)

    @besweeet

    If the slug of the custom post type is the same as the slug of the taxonomy, this plugin will not be able to identify it.

    Perhaps changing the slug of the custom taxonomy to something like /podcasts/series will work.

Viewing 1 replies (of 1 total)
  • The topic ‘404: /custom_post_type/custom_taxonomy_category/post_name/’ is closed to new replies.