Support » Fixing WordPress » 404 and 406 Errors, and General Wonkiness

  • Less than a week ago I tried to change the emoticon setting and the name of the default category for my blog. Instead of indicating that the process had took, I received a 404 page using the theme I had currently installed. This occurred regardless of theme or plugins and I later learned it was affecting all four of my blogs.

    A few days later, instead of the 404 page I started receiving a complete settings list. I also found none of the links on that page would work, so I would have to back out of the page using my browser’s back button before I could do anything else in the dashboard.

    About two days ago that changed to a 406 error page (Not Acceptable. An appropriate representation of the requested resource /wp-admin/options.php could not be found on this server.), supplied by my host. I could be wrong, but this particular change seems to coincide with an Apache upgrade my host made.

    In addition to that wonkiness, WP Super Cache is now telling me that the mod_rewrite module isn’t loaded when it’s there and the code is correct. I also discovered that all of my permalinks have changed from whatever assorted settings I had, to custom.

    My host insists that it is corrupted code. Well if it is then WP made it that way because, like I said, all four of my blogs are affected, and re-uploading WordPress has made no difference.

    I have tried disabling mod_security using ALL the various directives I’ve found on the forums. No luck. I even changed permissions from 644 to 755, just to make sure WordPress had access. Nada!

    I am at my wits end here. Can anyone possibly give me some ideas as to what to look for?

Viewing 1 replies (of 1 total)
  • Bump!

    My host gave me the correct set of rules to disable mod_security along with a warning not to leave it there unless I know WordPress is hole free (needless to say that puppy got yanked as soon as I tested the bad page). I’m still getting the 406 error. Uploaded the options.php page from 2.5.1. No help. Ungraded to 2.6.1 beta 2. Still not working.

    Would someone help me out? Please?!!!!

Viewing 1 replies (of 1 total)
  • The topic ‘404 and 406 Errors, and General Wonkiness’ is closed to new replies.