WordPress.org

Forums

404 after server moving (4 posts)

  1. keepclif
    Member
    Posted 2 years ago #

    Hello everyone,

    I need help:
    I just moved my multisite to my production servor (same host: 1&1).
    I have 4 websites: 3 for 3 different languages (fr, en, es) and the root one for redirections.

    I made the differents changes in the database in order to have my links updated :
    - I followed these steps: http://codex.wordpress.org/Moving_WordPress
    - and replace directly in phpmyadmin with this request UPDATE wp_x_comments SET comment_content = replace( comment_content,'old-URL','new_URL')

    My new websites aren't working totally. I can't see pages and have 404 results, but my header, menus, etc. are ok.
    In the admin, I can see each dashboard's language, but when I go to the network admin, I have this error:

    Erreur lors de la connexion à la base de données
    Si votre site ne s’affiche pas, veuillez contacter le gestionnaire de ce réseau de sites. Si vous êtes le gestionnaire de ce réseau de sites, veuillez vous assurer que MySQL fonctionne correctement et qu’aucune table n’a d’erreur.

    Le site xxxxxxxxxx.com Nous avons cherché la table wp_blogs dans la base de données xxxxxx. Est-ce correct ?

    Que dois-je faire maintenant ? Lisez la page de gestions des bugs (en anglais). Certaines des bonnes pratiques qui y sont présentées pourraient vous aider à comprendre ce qui a mal tourné. Si vous êtes toujours bloqué par ce message, vérifiez alors que votre base de données contient bien les tables suivantes :

    wp_users
    wp_usermeta
    wp_blogs
    wp_signups
    wp_site
    wp_sitemeta
    wp_registration_log
    wp_blog_versions

    I am lost and need your help please.

    Thank you,

  2. keepclif
    Member
    Posted 2 years ago #

    Hello,

    That is exactly what I did.

    Is there other things to do / verify ?

    Thank you,

  3. and replace directly in phpmyadmin with this request UPDATE wp_x_comments SET comment_content = replace( comment_content,'old-URL','new_URL')

    That isn't at all the directions for Multisite. There are very specific notes for how to do the search/replace for Multisite.

Topic Closed

This topic has been closed to new replies.

About this Topic