Support » Plugin: Site Kit by Google - Analytics, Search Console, AdSense, Speed » 403 Forbidden – Failed to create a new Analytics Account

  • Resolved newscreativ

    (@newscreativ)


    Hello,
    i tried to connect my website with Google Analytics, but everytime i try to create a new Account or Property i got a 403 Forbidden Error Page…

    Here you can see my Screenrecording

    I hope i will be able to connect my website with analytics soon. šŸ™‚

    Kind Regards

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support James Osborne

    (@jamesosborne)

    Thanks for reaching out. Unfortunately it looks like the screen recording is no longer valid or it doesn’t exist at that address. If you’d like to check and share the link once more I can take a look.

    Alternatively if you want to share the following information I’d be happy to investigate this with you:

    1. Your Site Health information. You can use this form to share privately if preferred.
    2. Is this the first time you’ve tried to setup Analytics on this site, or have you successfully setup the Analytics module previously?
    3. Do you see any console errors on the same screen where this message is displayed?

    Let me know if you have any questions on the above.

    Thread Starter newscreativ

    (@newscreativ)

    Oh sorry,
    i sent you the Data and the Video via the private form.

    Yes its the first time. I tried to connect it with the property i created in analytics, but Site Kit only found my Account without the property. I had only one option left, so i tried to create a new Account through Site Kit.

    Plugin Support James Osborne

    (@jamesosborne)

    Many thanks for sharing the additional insights. Based on the error I suspect there may be something at host level blocking setup. Firstly to rule out any plugin conflicts before we check your hosting provider please follow the steps below:

    1. Login to your site from a Chrome browser incognito window
    2. Install and activate the Health Check & Troubleshooting plugin.
    3. Navigate to “Plugins > Health Check & Troubleshooting > Troubleshoot”.
    4. From the same screen click on the “Available Plugins” tab at the top right and then click on the “Enable” option next to “Site Kit by Google”
    5. Attempt to create a new Analytics account from within Site Kit once more

    You can exit troubleshooting mode afterwards.

    If the same issue occurs please share whether you’ve been able to setup Site Kit before on this or another site on the same hosting solution. This can include selecting an existing property as opposed to creating a new one.

    Thread Starter newscreativ

    (@newscreativ)

    Hello,
    sadly that didnt work either. I contacted my hosting provider and asked if there is any problem with the servers but they told me that everything is fine. Its the first time i would like to use analytics on a Site. So my hosting provider told me that other people are using analytics within the hosting solution.

    The error:
    “Forbidden
    You do not have permission to access this document.
    Web Server at elegant-johnson.157-90-23-119.plesk.page”

    and the “elegant…”-Domain is the old WordPress Domain. But in php is no referenz to the old Domain.

    Plugin Support Abdullah Ramzan

    (@abdullahramzan)

    Hello @newscreativ ,

    As per Site Health information it seems maintenance mode was enabled. But I can access your site right now. Can you please apply basic troubleshooting again as mentioned above?

    Best Regards,

    Thread Starter newscreativ

    (@newscreativ)

    Hello,

    i tried it again, still the same problem. And i dont know why, but i never set the status of the Site to maintenance mode.

    Kind Regards.

    Plugin Support James Osborne

    (@jamesosborne)

    @newscreativ Just to keep you updated we’ve created the below GitHub issue as we investigate this further:
    https://github.com/google/site-kit-wp/issues/3532

    If you could provide the following that would be great as we try to determine the cause:

    1. Any console errors on the final page where you encounter this message (after clicking on the “Create Account” button
    2. Do you have any other WordPress sites on the same hosting platform which you can check whether you can create a new Analytics account within Site Kit from? It may be possible to use a service such as Softaculous or a once click install feature to install a new WordPress site

    I’ve added some temporary workaround steps to that GitHub issue which you can try in order to proceed. Hopefully this will allow you to get the Analytics module successfully connected. Let me know if you have any questions on this.

    Thread Starter newscreativ

    (@newscreativ)

    Thank you for your support! šŸ™‚

    1. My console Errors: “Failed to load resource: the server responded with a status of 403 ()”

    2. I will try it on another WordPress project but that will take some time.

    Plugin Support James Osborne

    (@jamesosborne)

    Thanks for the update. From checking your hosting provider it looks like ModSecurity is part of each plan. Are you able to check whether you can access this feature to make changes at host level?

    Plugin Support Bethany Chobanian Lang

    (@shetheliving)

    @newscreativ Thank you for your patience here! We’ve identified that this error is occurring due to a recent change in Mod_Security rules. While some hosting providers may be able to adjust these rules, others may not, so we’re going to apply an update in the next Site Kit release (before end of June) to fix this error in the plugin. I’ll update this topic again when the fix has been released.

    Plugin Support Bethany Chobanian Lang

    (@shetheliving)

    @newscreativ We’ve implemented a fix for this issue in today’s release of v1.34.1 of Site Kit. Please make sure that your Site Kit plugin is updated and you should be able to successfully set up Analytics now.

    I’ll mark this issue as resolved, but feel free to open a new support topic if you continue to encounter issues, or reopen this topic if you’re still having trouble and we’d be happy to assist. Thank you!

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.