Support » Miscellaneous » [Resolved] 403 Forbidden Error

[Resolved] 403 Forbidden Error

  • Ok, this is so weird that I had to post about it. I just posted this post:

    And the original had this paragraph in place of the fourth one down (not counting the edit as a paragraph):

    “When I had fully vacuumed the dog hair beneath where the bed had been and replaced it back in the prominent spot next to my bed, she wouldn’t come near it. Rather she decided to curl up in a ball in the corner of the room.”

    With that paragraph, I received a 403 Forbidden error when posting. So I removed all the text (because I knew I could post, I had not that long before with not a problem) and then added in each paragraph one by one….

    Anyway, it seems so random and weird and I can’t explain it. I tried it on another WP install I have running and it wouldn’t post there either.

    Strangest thing ever….
    EDIT: and for clarification (in case you don’t click over to the post), I was referring to my dog.

Viewing 15 replies - 16 through 30 (of 32 total)
  • “curl u” in fact triggers errors for me as well on an online app i’ve created. PHP 4ish and apache.

    in textareas or inputs.

    My host told me this:

    “Mod_security is restricting this and blocks all url’s with C-url. This is done because of some php worms that are spread using c-url. I would recommend trying to work around this. It will be a major security issue for us to allow this.”

    I have no problems with Curl or C-url and Mod_security on my server, but still get a 403. I’ve found that it does not matter how long the post is, just if I’m sending a trackback or if I have a link in the post. The second I take the link out of the post and hit publish or save or take any action of that sort it works. Works in so far as I can’t actually publish anything but do avoid the 403… Any thoughts on this?
    Also had issues with my permalink structure just recently. Two days ago it was fine with year/month/day/postname. It started to break earlier yesterday morning so I changed it without the day part and it worked fine… again, any thoughts on this would be great.

    Thanks everyone.

    Moderator James Huff


    Are you blocking referrers with keywords via .htaccess? Sometimes we block referrers with keywords and we don’t even think that it may catch and interfere with our own actions (such as editing posts).

    I’m blocking 5 ip addresses. I know they are spammers, so I didn’t think there would be a problem.

    The only thing in my .htaccess file is my mod_rewrite data that wordpress put in there.

    It seems like if the url I’m putting in a post is even somewhat long it 403’s it. It used tinyurl for a few links recently because of this. Is there some setting on that that I have overlooked?

    Thanks for the reply by the way.

    Moderator James Huff


    I believe that controlling the length of URLs is either an Apache or PHP setting, but I’m not sure. Have you brought up the fact that posting long URLs causes a 403 to your hosting provider’s support yet?

    I will post a ticket about it in a moment, just finishing up a final project for class…
    Would it possibly be just the content of certain URLs or the fact that they are long? Seems like the boundary is 32 char. But I have posted some that were over 42. Very odd, it works sometimes and not others. Has anyone else had this on/off permissions error before? Is it a bug in WordPress?
    Thanks for your help.

    Actually it seems to work fine right now. I haven’t changed anything, but I can now post longer links and haven’t had a 403 for about 16 hours now… Odd.

    Thanks again for your help, I’ll be back on here if it changes. Still not sure why it did this.

    So bizarre… I just have to give up the use of the word “curl”? But how will I live?

    I must admit, this blocking of the word “curl” is really annoying. you’d think that the code could be made elegant enough to allow basic grammar in a post.


    Moderator James Huff


    The problem is actually caused by over-zealous server-side security (such as mod_security) which blocks PHP executables (such as “curl”) from being sent via POST requests.

    I actualy needed to have the string “curl” in a post (referring to the UNIX command) and I just replaced all curl with c<!– –>url. Works great.

    Prehaps it would be a good idea to add a JavaScript replace all to look for curl and replace it with c<!– –>url? I will write the code if nobody else wants to.

    I had the same thing happen. I’d written a poem that had the word curl in it and it wouldn’t post. I changed it to curled and it worked fine. Thanks for the other tips, though.

    empfehlenswert: g├╝nstige notebooks http://www.com-winner.com auf dieser seite
    ausserdem viele n├╝tzliche links auf http://samsungnotebooks.sa.funpic.de und
    http://notebookshop.no.funpic.de aber auch auf http://gebrauchtepc.ge.funpic.de !!!



    Unresolved problem.
    I have the same problem described before. Its appear randomly…

Viewing 15 replies - 16 through 30 (of 32 total)
  • The topic ‘[Resolved] 403 Forbidden Error’ is closed to new replies.