Support » Miscellaneous » [Resolved] 403 Forbidden Error

[Resolved] 403 Forbidden Error

  • Ok, this is so weird that I had to post about it. I just posted this post:

    And the original had this paragraph in place of the fourth one down (not counting the edit as a paragraph):

    “When I had fully vacuumed the dog hair beneath where the bed had been and replaced it back in the prominent spot next to my bed, she wouldn’t come near it. Rather she decided to curl up in a ball in the corner of the room.”

    With that paragraph, I received a 403 Forbidden error when posting. So I removed all the text (because I knew I could post, I had not that long before with not a problem) and then added in each paragraph one by one….

    Anyway, it seems so random and weird and I can’t explain it. I tried it on another WP install I have running and it wouldn’t post there either.

    Strangest thing ever….
    EDIT: and for clarification (in case you don’t click over to the post), I was referring to my dog.

Viewing 15 replies - 1 through 15 (of 32 total)
  • I copied and pasted that and it displayed.
    Did you write it in a wordprocessor ? It’s the only possible thing I can think of – that a strange character has set wp off.

    Nope, I wrote it right in the admin panel – in both blogs that I tried it on. I have no explanation…it’s just incredibly weird.

    I’ve had the same thing happen to me on a couple of occassions. I can’t figure it out! Have you had any luck?

    Nope, no idea what caused it. It happened again with another post a few days ago actually. But no one’s been able to give me a reason why. *shrugs*

    maybe its the permissions ?

    I get a 404 not found message for that page.

    I posted the initial question ages ago – I since changed my permalink structure to leave off the /archives/
    It’s not permissions or anything I can truly understand. It’s just some random weird error that dislike some portion of the text in that sentence.

    You can try putting this in your .htaccess:

    DirectoryIndex index.php

    This will force Apache to accept nothing but index.php as your default file.

    I never saw this reply, sorry.

    Uh, how does that help me? My index.php is fine…I mean I don’t get errors viewing my site, it’s trying to post things that WP seems to dislike for no intelligent reason that I can understand, I don’t see how altering a file that is perfectly fine would help me solve a problem that apparently happens in post.php – and effects ANYTHING I try to do after posting the unpostable text, since I get a 403 in any direction, sans back, where I can then re-edit the post and try again.

    (Wow, that was so wordy.)

    Hey my friends blog is having the smae problem as well. short posts go through but longer ones just don’t. they get the 403 forbidden and 404 error.

    I have chmodded post.php as was suggested here

    . i have also had the host upgrade the zend php thing as it worked for some people.

    any ideas? it seems like alot of people are getting this error recently. she was posting fine when it suddenly happens.

    I’m getting the exact same problem. Posts under 130 words or 776 characters post just fine. Anything over that number generates a 403. Any help fixing this would be greatly appreciated.

    I’m continuing to get this same problem and it’s frustrating. I’m able to use an external program to post to my blog (ecto for the mac) but I can’t post through the normal web interface

    I’m still getting the same problem, and have tried enableing and disableing permalinks, deleting and changing .htaccess, I’ve changed permissions all the way up to 777 for /wp-admin, and still getting the exact same error as above.

    This sounds like it might be related to mod_security rules. Some of the example rules block anything that looks like an attempt to fire up a common downloader called curl via a malicious web request.

    Ask your host whether they’re using mod_security, and if so, whether they have any (overly-simplistic) rules that look for curl.

    Apologies for the sort of double posting (but in case someone finds this later I wanted to report in the original thread). I contacted my host regarding the issue and Kelson is correct that it is a mod_security thing.

    My host, however, is not willing to alter anything, but now that I know it’s the word “curl” that was causing the issue, I’ll just refrain from using it. (Not like it’s that common of a word for me anyway!)

    Thanks again, Kelson.

    it is confirmed… the post that triggered the 403 had the word “curl” in it too!

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘[Resolved] 403 Forbidden Error’ is closed to new replies.