Support » Plugin: GDPR Cookie Compliance » 403 Forbidden Error saving third-party cookies

  • Resolved efquintana

    (@efquintana)


    Hi,

    I want to change the current plugin to manage cookies for yours, but I have a problem configuring it.

    When I try to save the Third Party Cookies configuration with the Analytics code, I receive an error “403 Forbidden. Access to this resource on the server is denied!”

    If I add any other text I can save the configuration correctly. But not the Analytics script.

    The same goes for the additional cookies section.

    How can I solve that? Thanks in advance

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Moove Agency

    (@mooveagency)

    Hi @efquintana,

    Thanks for using our plugins.

    It seems a premission issue, you can try the following code snippet (should be added to functions.php)

    add_action( 'gdpr_options_page_cap', function( $capability ){
    	return 'edit_posts';
    });

    If it doesn’t help, you can try to switch your theme to a default WordPress theme and test the settings again. If you have some restrictions in your theme, this should be fixed by your developers.
    We also checked your site, and the wp-admin area is restricted, this could be related to this restriction, please disable the plugin / script (could be in .htaccess too) which make the above restriction, and try the settings. The wp-admin should be blocked only if the user is not logged in.

    Hope this makes sense.

    Hi.
    Thank you very much for answering.

    I have tried the code you propose but the error is still happening. I have also tried implementing it in Twenty Twenty Theme and it remains the same.

    As soon as wp-admin I don’t understand what you mean. Obviously that area is protected and if you try to access the system redirects you to wp-login, I do not understand what is the problem with that.

    If it helps, I just checked that I can save scripts in body, but not in header or footer.

    Plugin Author Moove Agency

    (@mooveagency)

    Hi @efquintana,

    We found an issue related to this topic, the issue is fixed in the latest version of the plugin (4.1.4), please update the plugin first and test if everything working as expected. If not, please follow the steps in our previous reply.

    Thanks

    efquintana

    (@efquintana)

    Thanks. Finally, my hosting support solved it. It was a problem with ModSecurity

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.