WordPress.org

Support

Support » Installation » [Resolved] 403 Forbidden

[Resolved] 403 Forbidden

  • Hi,

    I searched around and came up with topics relating to reinstalls and plug-in issues, but nothing like this.

    I just tried to install WP for the first time and everything went smoothly (set up apache serving static pages, database user and tables, etc) until I try to load the install.php file when I get an http error 403. I have WP in the /blog/ directory of my site. If I place a php file called test.php in my /blog directory it is accessible, if I move it to the /wp-admin/ directory I get a 403. If I rename the wp-admin directory and put a clean one in its place and move my test.php file inside I can access it. My files permissions are set to 644 and directories to 755. All of my other html pages on my site are accessible from the web. There is no .htaccess file in the wp-admin directory. Any hints? Is it WP, apache, php, or something else?

Viewing 5 replies - 1 through 5 (of 5 total)
  • So I’ve continued trying to figure this out and I’m stuck. Any help would be appreciated.
    I know php is installed because I can get to php pages on my server http://www.icymidnight.com/blog/helloworld.php
    I can’t get to the WP files though http://www.icymidnight.com/blog/index.php which have a different error message than files that do not exist http://www.icymidnight.com/blog/not_here.php

    Thanks for your time.

    I installed Fedora Core on a virtual machine to see if a brand new OS would run WP and not surprisingly, it ran without a hitch. I reinstalled the OS on my server, figuring I must have screwed up some obscure setting somewhere and I only use it for a web server so no biggy. Well after the reinstall, I still couldn’t get WP to run. Argh! Then I noticed that I installed it on my virtual machine by wgetting the tarball directly to the html directory and extracting. Did the same thing on my web server and bam! blog works. It appears to me that the file permissions are all the same so I have no idea why this started working all of a sudden. Any suggestions?

    Anyway, I marking it as resolved and hope that someone who runs into the same problem will find this useful one day.

    Hello.
    I tried to write with wp, but sometimes I can’t and I receive the next problem: 403 Forbidden.
    What can I do?

    I came back to this post, and just realised that I didn’t post my latest findings. The problem for me was SELinux. SELinux has its’ own set of file access permissions, and restricts the web server process from accessing files outside of the document root. When I transferred the tarball into my home directory and extracted it there, then copied the WordPress directory to my document root, the files carried the SELinux permissions that don’t allow them to be read by the web server process. Your two options are to download the tarball direcly to your website directory structure, or reset the SELinux permissions when you copy them from elsewhere on the server.

    Icy, I don’t understand half of what you said but I have run into the same problem. I am on a dedicated hosting plan and have WP in the main directory (not in a folder like “/blog/”). I upgraded from 2.0.* to 2.1.3 and now I get 403’s on the Options panel and managing pages. I was able to edit three pages after upgrading before I got the 403. Can you explain to me what I can do like I’m a six year old? 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] 403 Forbidden’ is closed to new replies.
Skip to toolbar