Support » Plugin: ThirstyAffiliates Affiliate Link Manager » 403 errors in Google Search Console on many affiliate links

  • Resolved kcaluwae

    (@kcaluwae)


    I use a 302 redirect for my affiliate links and they have the rel=nofollow attribute. These are the default settings for all my affiliate links.

    Still, I see a growing number of 403 errors in google search console.

    I verified in the developer tools that my links do have the nofollow attribute.

    Should I use the 301 redirect instead of the 302?
    Should I maybe add a “Disallow: /goto/” under “User-agent: *” in my robots.txt file?

    The red square “Bestel hier nu je huurwagen” on the linked page is an exemple of an affiliate link.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi @kcaluwae,

    Thanks for contacting us!

    Google shouldn’t follow links that have a rel=”nofollow” attribute. However, it may still appear in their index if other sites link to the page without using nofollow, or if the URLs are submitted to Google in a Sitemap. For more information regarding this, please visit this page: https://support.google.com/webmasters/answer/96569?hl=en

    Upon checking the affiliate link image on your page, it seems that the issue is related with the noscript tag. If you try to remove it using the developer tools, the error 403 disappears. Unfortunately, we couldn’t reproduce this issue on our end as this might be related to your server configuration settings. For now, I recommend not adding noscript tag and see if that helps resolve the issue.

    I hope this helps! Let me know if there’s anything else I can assist you with!

    I’m not sure if it’s related to the noscript tag.
    Another one of the 403 errors is coming from this affiliate URL :
    https://www.wapititravel.com/blog/goto/the-royal-park-hotel-kyoto/

    The error is found on this page.
    https://www.wapititravel.com/blog/en/3-week-itinerary-japan/

    Search for ‘Royal Park hotel Kyoto’ and you will find a section with 2 links. One in the text as a plain link and one at the bottom as a button. I’m not sure which one causes this 403 error but if I inspect the links with developer tools both contain the ‘nofollow’ attribute.

    FYI I checked the sitemaps, they do not contain the affiliate links.

    Hi @kcaluwae,

    Thanks for your response.

    It seems that the main issue is because the Googlebot is being blocked and this caused an additional issue with your images with affiliate links, which contains noscript tags.

    You could check this and reproduce the issue by following the steps below:
    1. Go to the page with an issue (https://www.wapititravel.com/blog/en/3-week-itinerary-japan/) and open the developer tools.
    2. Click on the Royal Park hotel Kyoto image and the developer tools will display an error 403 notice.

    If you refresh the page and remove the noscript tag by using the developer tools from the image:https://snag.gy/EcD1Sm.jpg, you’ll see that it doesn’t produce the 403 error anymore.

    To fix this, please remove the Googlebot in the list of Blocked bots on your ThirstyAffiliates > Settings > General.

    Please note that it is blocked by default to give you more accurate stats in the Reports page and removing it will affect the stats, as when Googlebot visits that link, it will be marked as clicked.

    I hope this helps! Let me know if you have any other questions!

    @supportray

    Thanks for getting back to me.
    I missed the 403 error on the hotel images. Thanks for pointing that out.

    Unfortunately removing googlebot doesn’t solve the problem. The noscript tag is still there and I’m still not sure that it’s (only) the noscript tag that causes the error. I did notice that removing the noscript tag solved the problem but I’m trying to understand what happens here and therefore did some tests on my staging site.

    On my staging site, which is an identical copy, I don’t have these issues.
    I see that the HTML that is being generated is different

    Staging : <a href="https://www.wapititravel.com/blog/wapiti-staging/?thirstylink=the-royal-park-hotel-kyoto"><img src="https://i2.wp.com/www.wapititravel.com/blog/wapiti-staging/wp-content/uploads/2018/06/royal_park_hotel_kyoto_sanjo.jpg?resize=300%2C262&ssl=1" alt="The Royal Park Hotel Kyoto Sanjo" width="300" height="262" /><noscript><img src="https://i2.wp.com/www.wapititravel.com/blog/wapiti-staging/wp-content/uploads/2018/06/royal_park_hotel_kyoto_sanjo.jpg?resize=300%2C262&ssl=1" alt="The Royal Park Hotel Kyoto Sanjo" width="300" height="262" /></noscript></a>

    Production : <a href="https://www.wapititravel.com/blog/goto/the-royal-park-hotel-kyoto/" title="The Royal Park Hotel Kyoto" rel="nofollow noopener noreferrer" target="_blank"><img src="https://i1.wp.com/www.wapititravel.com/blog/wp-content/uploads/2018/06/royal_park_hotel_kyoto_sanjo.jpg?resize=300%2C262&ssl=1" alt="The Royal Park Hotel Kyoto Sanjo" width="300" height="262" /><noscript><img src="https://i1.wp.com/www.wapititravel.com/blog/wp-content/uploads/2018/06/royal_park_hotel_kyoto_sanjo.jpg?resize=300%2C262&ssl=1" alt="The Royal Park Hotel Kyoto Sanjo" width="300" height="262" /></noscript></a>

    I did not compare both in great detail but as you can see the noscript tag is there in both instances. 1 difference I note is that on production I get a whole lot of attributes in the a-tag that I don’t have on the staging site.

    I added the link in the same way by editing the picture in wordpress and making it link to a custom URL where I entered the affiliate link manually.

    I used to have this picture attached to the affiliate link but I detached the image. I ‘m not quite sure if the attached images automatically generate links. I was hoping that this link would cause the attributes to appear (and somehow would have been broken on my staging site because of the copy) but that’s not the case.

    I tried to remove the extra attributes in the developer tools but as soon as I remove an attribute I seem to break my link. Clicking the image doesn’t do anything anymore. Compare this to the faulty scenario where clicking the image opens a blank new page and shows 403-error in the console.

    ThirstyAffiliate’s settings on both enviroments are the same. Further insights on why these attributes appear on production and not staging would be helpful.

    • This reply was modified 1 year, 5 months ago by .
    • This reply was modified 1 year, 5 months ago by .

    Hi @kcaluwae,

    Thanks for keeping in touch.

    Upon checking, I noticed that the image with the affiliate link URL is still blocked from Googlebots.

    To assist you further, would you please provide us with a temporary admin credential to your live site and staging site so we can investigate the issue and run some tests? Also, please reply using our Thirsty Affiliates support form and mention that I’m assisting you regarding this issue. https://thirstyaffiliates.com/support/support-request-form

    Thanks in advance and I look forward to your reply.

    Done.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘403 errors in Google Search Console on many affiliate links’ is closed to new replies.