Support » Fixing WordPress » 403 error when trying to upload images

  • I recently upgraded to 2.3.3, last week everything was fine. NOTHING was changed o my end, yet today for some reason I cannot upload images within wordpress.
    wp-content is set to 755
    the proper directories are in place
    I’ve even reset the permissions to make sure.

    Still, whenever I try to upload an image i get a 403 error confined to just my upload portion of wordpress. I can, however, view uploaded content.

    Not sure what’s going on here.

Viewing 1 replies (of 1 total)
  • I had a similar problem with my blog. Was fine until I upgraded to 2.5.
    If you have exhausted all other avenues, I would contact your host. My host (Hostgator) was blocking the upload of images for security. I had to tell them the location of all of my blogs so that they could remove the security feature. This worked perfectly.

    When I was getting the problem I was just getting “http error”, but I know some people got “crunching” instead.

    It seems that the server was logging this message: mod_security: Access denied with code 403. Pattern match “^Shockwave Flash” at HEADER(“USER-AGENT”) [id “***MY ID”][rev “1”] [msg “SpamBot UA”] [severity “CRITICAL”] [hostname “***MY-DOMAIN***”] [uri “/testing/blog/wp-admin/async-upload.php”]

    Hope this helps you guys. I spent hours trying sugegsted fixes. I never would have guessed that it was a security issue with my host. After contacting them it was fixed within the hour.
    At first they argued that it was 3rd party software, but I told them that I had a test blog and I also had blogs on 2 servers and it was the same on all of them. They referred me to their higher level support and they fixed it within an hour.

    Let me know the outcome.

Viewing 1 replies (of 1 total)
  • The topic ‘403 error when trying to upload images’ is closed to new replies.