Support » Plugin: Help Scout » 403 Error when saving settings with Beacon

  • Hi,

    Whenever I add the Beacon code into the plugin settings and then try to save, I get an error – “403 Forbidden Access to this resource on the server is denied!”

    The beacon code I’m adding is straight from the HelpScout website…

    <script>!function(e,o,n){window.HSCW=o,window.HS=n,.....document,window.HSCW||{},window.HS||{});</script>

    Here’s a screenshot of the error: https://cl.ly/1i1s0X3v343D

    Hoping you can help.

    Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Dan Cameron

    (@dancameron)

    Hello Anthony,

    Please reach out to Help Scout’s support on their site.
    https://www.helpscout.net/get-help/

    They can better help you with this since it seems like an issue with the script they’re providing.

    Regards,

    Hi Dan,

    Thanks for getting back to me. Wouldn’t it be an issue with the actual plugin though? The error I received was when I tried to save the plugin settings, so the script shouldn’t be getting executed at this time.

    If I received the error on the front-end, I could totally see it being an issue with the HelpScout script, but the error was in the Dashboard when I simply tried to save the script in the settings.

    Plugin Author Dan Cameron

    (@dancameron)

    Hi Anthony,

    You’re right, I misunderstood, apologies.

    This is a very odd error though, something that shouldn’t happen since a 403 error is something that comes from a server configuration. I looked around and couldn’t find anyone reporting an issue like this with WordPress, even though I found a lot of similar issues (e.g. http://www.wpbeginner.com/wp-tutorials/how-to-fix-the-403-forbidden-error-in-wordpress/).

    It seems as though, since WordPress handles the option saving, and the Help Scout plugin simply uses the WP settings API that this type of issue with other options being saved on your site. Does it only happen for this one option?

    All I can suggest is logging out of your site, clearing cookies for your site, and attempting to save the option again. If that doesn’t work you may want to look at some of your active plugins, and see if any handle site access.

    Let me know if you find anything helpful.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.