Support » Everything else WordPress » 403 error on first-time svn commit to trunk

  • (Created new “unresolved” post; related to this post.)

    $ svn –username snapshots –password **** ci -m “Initial version”
    Adding trunk/
    svn: Commit failed (details follow):
    svn: CHECKOUT of ‘/!svn/ver/18251/snap-shots-for-wordpressorg/trunk’: 403 Forbidden (

    I’d appreciate it if someone could help me out.

    The account username/pwd works fine to login to the forum. Is there another privilege I’m missing to access


Viewing 14 replies - 1 through 14 (of 14 total)
  • I have the same problem at the first checkin:

    $ svn ci -m ‘Adding 0.1 Plugin Version’ –username Xxxxx –password xxxxx
    Aggiungo trunk/help.txt
    svn: Commit fallito (seguono dettagli):
    svn: CHECKOUT di ‘/!svn/ver/21327/wiki-dashboard/trunk’: 403 Forbidden (

    Now it worked (with a smaller description)
    $ svn ci -m ‘0.1’ –username Xxxxx –password Xxxxx
    Aggiungo trunk/help.txt
    Aggiungo trunk/mini-wiki.php
    Aggiungo trunk/
    Aggiungo trunk/readme.txt
    Aggiungo (bin) trunk/screenshot-1.jpg
    Aggiungo (bin) trunk/screenshot-2.jpg
    Aggiungo (bin) trunk/
    Aggiungo trunk/wiki-dashboard-en_US.po
    Aggiungo (bin) trunk/
    Aggiungo trunk/wiki-dashboard-it_IT.po
    Aggiungo trunk/wiki.txt
    Aggiungo trunk/wikidashboard.php
    Trasmissione dati …………
    Commit della Revisione 21333 eseguito.

    i have this error:
    Error: Commit failed (details follow):
    Error: CHECKOUT of ‘/!svn/ver/27378/mitsukaranakatta/trunk’: 403 Forbidden (

    :s my data login is very good

    I have same trouble:
    svn ci -m ‘First version’ –username ****** –password ******
    Adding trunk/readme.txt
    svn: Commit failed (details follow):
    svn: CHECKOUT of ‘/!svn/ver/42374/syndicate-bigfishgames/trunk’: 403 Forbidden (

    I have the same trouble with one of my plugins. All other plugins (older and newer ones) work fine.

    Hinzufügen trunk/functions.php
    svn: Übertragen fehlgeschlagen (Details folgen):
    svn: CHECKOUT von »/!svn/ver/42387/projectmanager/trunk«: 403 Forbidden (

    I’m also having the same problem with the error 403 Forbidden ( tried with/without password, changing password and with a three character description.

    Any help?

    I’m also having this problem.

    It’s very frustrating as no one seems to post any definitive ways of fixing this problem. I have tried the following:

    • Limiting my message to as little as 1 character
    • Checking out the repository via https and checking it back in on the same
    • Removing the local repository and starting again from scratch
    • Committing different files individually
    • Changing my password on the different sites: and
    • Doing the check in while I’m logged out of the sites
    • Doing the check out after logging back in to the sites

    As you can see, I’ve tried just about anything reasonable that I can control. At this time, I’m starting to think that there is just some sort of configuration issue on their side, and for whatever reason, they aren’t willing to deal with it at this time.

    Should I just launch a new plugin request with a new name, wait the few days to get that one approved, and then add my renamed plugin to that one? Is that the only realistic solution at this point?

    We are having this trouble with a brand new plugin. The fact that these threads about 403 errors goes back months is not a good sign.

    Has *anyone* from the WordPress site responded in any way?

    Update on my situation…

    I previously sent off bug reports and a message to Matt Mullenweg, neither of which produced a response.

    However, I was just able to successfully commit my first changes to my plugin’s repository. I received an email a couple of hours ago telling me that my repository would be ready in about an hour. I waited longer than an hour to be sure, and my commit took.

    From what I can tell, these 403 error problems come from the fact that the accounts haven’t fully been set up. They appear to be set up, but they are not. So, the documentation about the process and the process itself definitely needs to be improved. The documentation about submitting a plugin should indicate that you have to wait until you receive the email message and follow its instructions before being able to commit changes to the repository.

    Anyways, I hope that every else experienced the same and that this process can be enhanced to prevent these headaches in the future.

    Just had the same experiance as chris did – received an email saying the plugin had been approved and the SVN repository would be available.

    Serious disconnect between the site FAQ and docs and reality – wooo! 😉

    Now if I can remember what the password I used was ….

    I’m having trouble with my first commit also:

    Commit failed (details follow):
    MKACTIVITY of ‘/!svn/act/3c75b966-33f4-43b8-9a8d-650ceabb5b35’: authorization failed (

    Is this the same sort of thing or am I doing something wrong? I’m using Versions on Mac – maybe that doesn’t work with wp-plugins’ svn?

    I’m using Version on Mac too. Need help to get rid of :

    Commit failed (details follow):
    MKACTIVITY of '/!svn/act/b697a22e-7f64-11dd-909a-a3b07d027987': authorization failed (

    Please help me.

    For Reference: I just realized that the username is case-sensitive.

    I’m having the same problem, can this be a mac issue? I’m on mac to 😉

    Before we get any help, maybe we can find things common to our problem?
    * I am Mac user
    * This is my first plugin
    * this is the first time i use svn (version 1.4.4 (r25188))
    * I did receive a mail saying “Within one hour, you will have access to your SVN repository at <url>” at 30 september 2008 12:09:26 GMT+02:00
    * All commands worked fine until the last one from part 1 from

    pleas check witch ones are true for you, and add you own details.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘403 error on first-time svn commit to trunk’ is closed to new replies.