Support » Fixing WordPress » 403 error on comment post

  • Hi, I have read the archives and through most of the posts about 403 errors. However, nothing I’ve read so far is helping me with this problem.

    My blog is functioning otherwise normally. I can post, people can comment. However, a friend of mine emailed me today to say that everytime he tries to post this—

    I certainly agree with you both about Zope: I can barely understand what it is, but I’d always assumed that’s because my needs are relatively modest.

    But isn’t a framework just a big library? Even the smallest libraries have expectations about inputs and outputs. What would Zope be like if it were a library instead of a framework?

    As to why pythonistas are particularly prone to writing frameworks, I can only imagine that it’s because python scales so well, in terms of both computing power and number of people involved in the project. It’s very easy to start off small and build up as your needs/desires increase to something very large. As long as you refactor as you go, the framework you end up with is as efficient and as fun to hack as the little script you started off with.

    I’m currently in danger of writing a framework or two myself: I’m writing some python wrappers for things like HTK (ASR toolkit) and festival (TTS toolkit). Part of the point of writing these wrappers is to allow the users to keep to the file formats and work patterns they’re comfortable with, so framework-type lock-in would obviously be inappropriate. But it also makes sense to have a single wrapper with a clearly defined and documented interface – that sounds like a framework. What should I do?

    —as a comment to my blog he gets a 403 error. He has successfully posted the first two paragraphs, but something in the third and fourth paragraphs are causing a problem. I’ve tried editing his comment myself and added the remaining two paragraphs. I’ve tried posting the comment myself. Same problem – 403.

    I just tried adding the remaining two paragraphs word by word to his original comment and I get as far “python scales” in the first sentence of the third paragraph. “python” is fine, but adding the word “scales” or any other word after “python” gives me a 403 error. I don’t understand because I don’t believe it is a word length problem, as people have successfully posted much longer comments to my blog before.

    Does anyone know what might be causing this?

Viewing 2 replies - 1 through 2 (of 2 total)
  • skippy



    Might it be your web host using something like mod_security, trying to filter out malicious attacks? Since python is an interpreted language, and python scripts can be executed as python, it’s possible your host is trying to protect you.

    Yes, that does seem to be it. I first tried replacing all occurrences of “python” with “Python”, but that didn’t work. I then replaced all occurrences of “Python” with “[P]” and that did work.

    I doubt my hosting service would disable mod_security even if I wanted them to, which I don’t. But given that I do blog about python sometimes, there must be a better workaround.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘403 error on comment post’ is closed to new replies.