Support » Localhost Installs » 403 error after trying to change admin password

  • Hello,

    I have WordPress installed locally under MAMP (Mac OS X Lion), and recently attempted to change my admin password via the Admin UI. When I tried to save the change, I got a 403 error, and am no longer able to login to my WordPress installation. Interestingly, I can still view the WP installation (at http://localhost:8888/wordpress/ ).

    Error 403
    We're sorry, but we could not fulfill your request for /wordpress/wp-login.php on this server.
    You do not have permission to access this server. Data may not be posted from offsite forms.

    I have tried resetting my WP password through phpMyAdmin, but to no avail.

    Are there other workarounds or things I should check? TIA!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Okay. As a [temporary?] workaround, I disabled all plugins at once by moving them into another folder. Suddenly, I’m now able to login to the Admin UI, and successfully change my password therein.

    This looks like it might be due to one of my many plugins. It’d be a long process to see which one(s) conflict with changing a password in the Admin UI, so I’ll search around to see if known problems have already been reported — before testing one at at time.

    Fwiw, here is my plugin list; yep, some of them have been orphaned. Unable to grab version numbers at present since they’re disabled from the UI, although I keep the latest versions of them, where actively developed. Also unable to remember which ones were active for the same reason (most are, a few are disabled) — although I can look at one of my live sites (similar installations) and take a guess (denoted with [d]).

    [d] AF Extended Live Archives
    Bad Behavior
    Comment Email Responder
    Custom Query String
    [d] Filosofo Comments Preview
    Google XML Sitemaps
    Link Library Listed
    Login Stayput
    No Self Pings
    Search Everything
    Simple Tags
    Spam Karma 2
    [d] WP db Backup
    [d] Yadis
    Yet Another Related Posts Plugin
    [d] Zenpressed

    Of anyone knows of plugins that’d cause password changes to result in 403 and prevent Admin UI access, it’d be great to know. Also wonder if it might be due to a combination of plugin with localhost installation — but if the latter isn’t relevant, is there a way to move this thread to the Plugins and Hacks forum?

    I found the culprit plugin: Bad Behavior v2.2.3.

    You are running WordPress on a non-standard port. This configuration is not fully tested. For the moment please try enabling the offsite forms option in Bad Behavior’s settings.

    I turned on the “Allow form postings from other web sites (required for OpenID; increases spam received)” option, and clicked the Update button. Unfortunately, I still get the 403 error.

    I’ll look into seeing if I can change the port for my local MAMP installation to something more standard…

    Looks like port 8888 is the default Apache port for MAMP. Apparently I can set it to 80, but that will cause me to be prompted for my Mac’s password (the case for anything less than port 1024, iirc). I’ll see if port 8080 (also used in some Apache installs) will work…

    I’m having the exact same problem with this; I’d like to enable the offsite forms in BB settings, but BB won’t allow me to change the settings, and when BB is deactivated, I have no access to the BB settings. According to the BB site, WordPress ignores settings.ini, so I need to get at the preferences elsewhere. But where?

    (update: forgot the details: Mac OS 10.6, using MAMP, up-to-date versions of everything.)

    I don’t know if anyone’s still looking at this, but the obvious workaround for the Bad Behaviour options problem is to disable the plugin altogether. For a local installation of WP (without any access from outside) Bad Behavior won’t actually do anything useful anyway, will it?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘403 error after trying to change admin password’ is closed to new replies.