• Resolved kenteush29

    (@kenteush29)


    Hi there, I hop you’re doing great !
    A customer (who’s also a developper) reported that the back in stock notification doesn’t work and create a 403 error. Here is the message :

    I get a 403 error. Here are the details, you can give them to your webmaster and he should be able to diagnose the problem.

    Request URL: https://kula-tactical.com/wp-json/in-stock-mailer/v1/product/987599583

    Headers:
    ity: kula-tactical.com
    :method: POST
    :path: /wp-json/in-stock-mailer/v1/product/987599583
    :scheme: https
    accept: */*
    accept-encoding: gzip, deflate, br
    accept-language: fr-FR,fr;q=0.9,en-US;q=0.8,en;q=0.7
    cache-control: no-cache
    content-length: 55
    content-type: application/x-www-form-urlencoded; charset=UTF-8
    cookie: _ga=GA1.2.1776380131.1599235041; wof-987611049=1; _hjid=c706d7b1-c8bb-4492-a671-1410c21e1e7c; __stripe_mid=1c22bc5d-13ab-44e8-b143-d9e59ea27d6b80dbba; mailchimp_user_email=fa.corneau%40gmail.com; wordpress_logged_in_7e537974d3348c9916072eabb95d8b97=fa.corneau%40gmail.com%7C1607708898%7CHqp3JrMgBK7LArWFKkecbx4Yjrh7MENelGNBjciFcka%7Cded9e7ecc0276ef36e5d0daa700f70fb345773b91c8b04d8ad985d4c9b0eaad2; mailchimp_landing_site=https%3A%2F%2Fkula-tactical.com%2F%3Fwc-ajax%3Dget_refreshed_fragments; _gid=GA1.2.758447926.1606727120; wmc_ip_info=eyJjb3VudHJ5IjoiRlIiLCJjdXJyZW5jeV9jb2RlIjoiRVVSIn0%3D; wmc_current_currency=EUR; wmc_current_currency_old=EUR; _gat=1; _gali=in-stock-form
    origin: https://kula-tactical.com
    pragma: no-cache
    referer: https://kula-tactical.com/sr3-magazine-airsoft
    sec-fetch-dest: empty
    sec-fetch-mode: cors
    sec-fetch-site: same-origin
    user-agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.66 Safari/537.36
    x-requested-with: XMLHttpRequest
    x-wp-nonce: e8687

    Form Data:
    email: fa.corneau@gmail.com
    mchimp_consent: true
    hname:

    Response status: 403
    Response body: {“code”:”rest_cookie_invalid_nonce”,”message”:”Cookie nonce is invalid”,”data”:{“status”:403}}

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author Frank

    (@frankspress)

    Hi @kenteush29 ,
    from the header I can see right off the bat: "Response body: {“code”:”rest_cookie_invalid_nonce”";
    Seems like the cookie session on their browser has been invalidated. Best solution is log out from WordPress then log back in. That should fix the issue.
    Frank

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.