403 during install on step 5 (Run the install script) (6 posts)

  1. tarak
    Posted 9 years ago #


    I am following the detailed instructions and get stuck
    on step 5 (Run the Install Script). I get a 403 when I try
    to access: http://<my server>/blog/wp-admin/install.php.

    Browser output:
    You don't have permission to access /blog/wp-admin/install.php on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

    Error Log:
    (13)Permission denied: access to /blog/wp-admin/install.php denied

    All the files are owned by apache:apache and have permissions 777.

    I have already installed mediawiki on this box, so php
    seems to be working fine. This is a RedHat box running

    There are no .htaccess files starting from the DocumentRoot.

    Can someone help?

  2. moshu
    Posted 9 years ago #

    Files never need 777 to work - at least in my experience.
    With the default 644 the install always works for me.

  3. tarak
    Posted 9 years ago #

    I tried 644 755 and 777. Neither of them worked. My guess is its not file permissions but something else, but I provided the information in case I was missing something.


  4. tarak
    Posted 9 years ago #

    This worked:

    Initially, I had moved the directory where the tarball
    was untar-ed to the html directory and changed the permissions.

    That did not work. Later on, I created a directory and
    copied all the files to that directory. That worked fine.
    What could have been the reason?

  5. moshu
    Posted 9 years ago #

    Probably it's an ownership issue: when you used the untar-whatever... maybe the owner was not you but the server or... ?
    I am not a server expert but I remember cases when manipulating things on the server resulted in different ownership than in the case of you creating it and uploading the files.

  6. tarak
    Posted 9 years ago #

    In all the cases - untar, move, copy, the user was 'root'

Topic Closed

This topic has been closed to new replies.

About this Topic