Support » Fixing WordPress » 400 Bad Request when trying to update permalinks

  • First post from a WP newbie:

    I have installed Wp, added .htaccess and changed permalinks. Everything has worked fine until a couple a days ago when I started to get 400 Bad Request errors when updating things from the Dashboard. The full error message is:

    Bad Request
    Your browser sent a request that this server could not understand.
    Client sent malformed Host header

    The first time it occurred was when I tried to install All-in-one-SEO pack. Most things I can work around by uploading things by FTP, but the biggest problem is that I cannot change the permalink settings except back to default (which I did, and now I’m stuck with “not-so-pretty” links).

    I can change some things (like themses and editing files) but not all (like changing permalink setting) without the 400 error.

    Any good tips or workarounds?

    My troublesome site is (clip art, cartoons and portfolio links at the top don’t work at the moment due to the permalink problem)


Viewing 8 replies - 1 through 8 (of 8 total)
  • I’ve encountered this same problem after upgrading to WP2.3. Firefox or IE give troublesome replies about Bad Request. I can change to default permalinks but custom permalinks will generate the Bad Request.

    I’ve been using WP for years now with 3 websites and I’ll be surprised if this topic even gets any attention. I think WordPress is great but support is about the worst they come. Problems become quickly overwhelmed from the volume of posts. Good luck with this gnurf, If I come across a solution I’ll post back here.

    It was the ISP who had done something… I contacted the support and after they turned off the ModSecurity on the web server (Apache, what else) everything started working OK again. So I suggest you contact your server admin (or if you administer your own web server, check if you have made any updates that may have turned on the ModSecurity).

    Before they turned it off I also got the suggestion to the following lines in the .htaccess file

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off

    …but that didn’t work.

    Best regards,

    I had the same problem…only a bit bigger. The “new” server they switched me to didn’t like they hyphen character in my blog title and once they switched it to underscore. I made the switch in my wp-config file and linking to it (the main page) was better but I still can’t access archive posts through the search or link functions. 🙁

    Here’s part of the error message:
    <quote>An invalid request was received. This may be caused by a malfunctioning proxy server or browser privacy software. If you are using a proxy server, bypass the proxy server or contact your proxy server administrator.</quote>

    It’s still not resolved. Have you had any luck?

    Thanks in advance,


    Hmmm… i am trying out wordpress for the first time, and i get the same 400 error when trying to update permalink structure. i am running it on my own, standalone machine (linux, apache, mysql, wp2.3). i am not using mod_security with apache. any thoughts?

    thanks in advance,


    Hi everyone i am having same error when i try to change the permanlink setting it shows me Your browser sent a request that this server could not understand.I am runing apache on fedora core
    can anybody help me ?

    I had the same trouble – setting up a brand new site – worked fine without using any permalink structure, but the minute I chose something (even one of the standard suggestions) it generated this error.

    After much conversation with my hosting provider, it turned out that the htaccess file was writable (777), and when wordpress tried to update it, some other security setting on the server had a fit.

    The fix – log into the file manager in cPanel or Plesk, change the permissions on your htaccess file to 644 (rw- r– r–) and all should be good.

    Well, it was for me anyway!

    I have the same error but only in my site online, i installed a webserver in my local machine and everything is fine.. so i did my changes in my local machine and copy the options directly from the database in the table “wp-options” the fiel “permalinks” and only copy the value and upgrade my site’s database. I know this is not the solution but it works for me.

    I had the same problem, it was resolved by adding this to the httpd.conf:

    SecRuleInheritance Off

    as in:

    <VirtualHost *:80>
    DocumentRoot /var/www/html/blog
    ServerAlias *
    SecRuleInheritance Off

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘400 Bad Request when trying to update permalinks’ is closed to new replies.