Support » Plugin: Responsive Lightbox & Gallery » 400 (Bad Request)

  • With ajax pagination there is an error in Firefox ( Failed to load resource: the server responded with a status of 400 (Bad Request) /wp-admin/admin-ajax.php:1 )

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • I Found problem
    Plugin don’t have ajax function for no login users – in “responsive-lightbox/includes/class-galleries.php” need add_action ‘wp_ajax_NOPRIV_rl-get-gallery-page-content’

    Hello,
    looks like you encountered a similar problem to what i’m facing – ajax not being enabled for logget out users.
    Did you fix the issue yourself? I see that your website appears to be working as normal now, and I have limited experience with ajax. Could you maybe share the full code for the fix if you did fix it? I Would be forever grateful, as it seems the plugin author doesn’t respond much here.

    Thank you in advance!

    Hi
    In plugin file – responsive-lightbox/includes/class-galleries.php
    After line – add_action( ‘wp_ajax_rl-get-gallery-page-content’, array( $this, ‘get_gallery_page’ ) );
    Try add line – add_action( ‘wp_ajax_nopriv_rl-get-gallery-page-content’, array( $this, ‘get_gallery_page’ ) );

    Thank you so much – this worked just as I wanted! You are the best 🙂
    I’m adding this solution to my topic as well so more people can see it if they encountered the same problem.

    Plugin Author dFactory

    (@dfactory)

    Will be fixed in the next release.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘400 (Bad Request)’ is closed to new replies.