WordPress.org

Forums

[resolved] [4.0 beta 4] bundled copy of Akismet (18 posts)

  1. Socially Uncensored
    Member
    Posted 1 year ago #

    Akismet
    You have version 3.0.1 installed. Update to 3.0.2.

    The beta should be bundled with the latest version. Currently 3.0.1 is bundled, while 3.0.2 has been out for a few days.

    My site auto updates and I seem to always have to manually update Akismet, because it is overwritten and essentially downgraded. I'd like it if the current was bundled so this wouldn't happen.

    I opened a ticket regarding this since it should be resolved before the final version.
    https://core.trac.wordpress.org/ticket/29266

    But I'm opening this forum post as well given that the tracker has tickets still waiting review going back since June / July.

  2. Please don't post here AND make a trac ticket. We mark posts resolved once we have a trac ticket.

    If you put this in your wp-config.php, you won't get Akismet upgraded out of sync anymore

    define( 'CORE_UPGRADE_SKIP_NEW_BUNDLED', TRUE );

    This kind of issue has been around for a long time. We know it's an issue, but we also assume that if you're willing to be on beta/alpha/trunk, you're willing to be a little more hands on with things :)

  3. Socially Uncensored
    Member
    Posted 1 year ago #

    I am willing to be more hands on with things. This was me reporting something that needs to be addressed... ie... adding a new version of Akismet

  4. ANTi-CAP
    Member
    Posted 1 year ago #

    I was also about to mention this, but that code will do me. I assume it leaves only Akismet alone?

    Regards,
    A

  5. ClaytonJames
    Member
    Posted 1 year ago #

    @ANTi-CAP

    I assume it leaves only Akismet alone?

    I believe it might leave anything in the /wp-content directory that comes bundled/included in WordPress (default themes and plugins) alone. Not just Akismet.

  6. ANTi-CAP
    Member
    Posted 1 year ago #

    I guess that's fine if the themes are not updated but they surely often are. I have turned of my version hiding for now and used the code above but if it does not work out I will just click the nightly button.

    Maybe there is a reason but I can't see one why not to put the 3.0.2 folder in the beta package?

    Regards,
    A

  7. ClaytonJames
    Member
    Posted 1 year ago #

    "Development updates will always re-install bundled themes & plugins.

    Main release updates won't restore bundled themes & plugins when they've been removed, but it will install NEW items (so 3.7 will install twentyfourteen when you upgrade). If you don't want to install bundled themes & plugins (both in dev and stable), you can define CORE_UPGRADE_SKIP_NEW_BUNDLED as true in your wp-config.php"

    Source: http://wordpress.org/support/topic/37-beta-1-automatic-background-update-restore-deleted-themes?replies=15#post-4717051

    I don't believe anything has changed since that info was posted.

    [edit] Regarding Akismet:

    "I can't see one why not to put the 3.0.2 folder in the beta package?"

    I think I read some similar sentiment expressed in a trac ticket a while back, but don't recall for sure.

  8. ANTi-CAP
    Member
    Posted 1 year ago #

    I'm running 4.0-beta4-20140823 but it still keep coming with the older Akismit. I' guessing this is what Socailly is saying also. When you are installing often it;s just a slight nag is all.

    Regards.
    A

  9. ClaytonJames
    Member
    Posted 1 year ago #

    I personally don't sweat it too much on Beta versions, but there is some good conversation about it on this ticket:

    https://core.trac.wordpress.org/ticket/28935

  10. Malae
    Member
    Posted 1 year ago #

    I thought I had been dreaming, when Akismet reverted from 3.0.2 to 3.0.1 in WordPress 4.0-beta until I realised that it is because it is bundled with the core files, which still have 3.0.1. It is technically a bug in the beta and can be accepted, but it is a pain and one wonders why the long wait to put Askismet 3.02 in the beta.

  11. ANTi-CAP
    Member
    Posted 1 year ago #

    Ahhhh.. and wow I had a quick look on that link and ran. A bit heated over nothing I'm off to bed, far to late and drunk for me. Just had an email saying 46 files from my test site have been modified.

    Should I be worried? Funny night. Take care all :)

  12. Just put this in your wp-config.php

    define( 'CORE_UPGRADE_SKIP_NEW_BUNDLED', true );

    It works, it stops Akismet from being a pain in the RARE occasions it;s out of sync. And yes, this is very rare. Happened twice in 3 years.

  13. Malae
    Member
    Posted 1 year ago #

    Mika,
    I did.
    It does.
    Thanks.

  14. Socially Uncensored
    Member
    Posted 1 year ago #

    I cannot remember what it was, but adding

    define( 'CORE_UPGRADE_SKIP_NEW_BUNDLED', TRUE );

    Blocked more than just Akismet (its documented somewhere, but I can't seem to locate it at this time). I believe the skin / style maybe one of them.

    This isn't ideal (good) for those of us who want all the newest bundled goodies (new skin updates for example) or view what other bundles may be included.

    So adding this code limits a complete beta testing (in my opinion).

    As someone else said...

    "I can't see one why not to put the 3.0.2 folder in the beta package?"

    I think I read some similar sentiment expressed in a trac ticket a while back, but don't recall for sure

    That someone else was me :-)

    And at the time it was concerning 3.0.1 and they did include the folder into the beta. I was hoping they would do the same again.

  15. ANTi-CAP
    Member
    Posted 1 year ago #

    That makes sense. The line has been removed from my config.

    Regards.
    A

  16. Blocked more than just Akismet (its documented somewhere, but I can't seem to locate it at this time). I believe the skin / style maybe one of them.

    Well. Yes. If you think about it logically it blocks all the 'bundled' themes and plugins. The default themes, hello dolly, akismet.

    It does NOT prevent them from being updated if there are new versions, it just stops the core installer from doing that for you.

  17. ANTi-CAP
    Member
    Posted 1 year ago #

    I modded my 2014 theme with a quite hard to find extension plugin to centre it and make some other changes, and the obvious background and header image changes.

    It seems to not be affected with the updates :)

  18. DO NOT MODIFY THEMES, PLUGINS OR CORE DIRECTLY, UNLESS YOU ARE THE DEVELOPER!!!

    Just ... Don't.

Topic Closed

This topic has been closed to new replies.

About this Topic