Support » Requests and Feedback » 4.9 problems

  • b747fp

    (@b747fp)



    i have had nothing but problems with WordPress since 4.9 released. Cannot edit any theme files using the stupid new editor. My feedback is, undo whatever nonsense you added to this release, it will not let me edit theme files on any of my sites, even fresh installs. Have to go back to the days of editing everything on FTP (lame). Whatever the purpose of this new feature was, it is not useful.

    That is my feedback.

    I know there are many topics about this and that many others are having the same issue, so common sense would say let’s undo whatever we messed up.

    “Unable to communicate back with site to check for fatal errors, so the PHP change was reverted. You will need to upload your PHP file change by some other means, such as by using SFTP.”

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator t-p

    (@t-p)

    Have you tied:
    – deactivating ALL (yes all) plugins temporarily to see if this resolves the problem (plugin functions can interfere). If this works, re-activate them individually (one-by-one) to find the problematic plugin(s).
    – switching to the unedited default Theme (Twenty Seventeen, etc.) for a moment using the WP dashboard to rule out any theme-specific issue (theme functions can interfere like plugins).

    If that does not help, please install the health check plugin and review the results.

    b747fp

    (@b747fp)

    This is happening with brand new installs, i have read the threads on the support forum i just am making a nastygram feedback that this new feature is extremely inconvenient to people like me who manage hundreds of wordpress sites. I’ve had to use Cpanel File Manager and FTP more this past month than I have all year, thanks to this “new feature”… I would like to see it removed or have an Option to turn it off.

    Dion Designs

    (@diondesigns)

    As a plugin author and server administrator, I’m in the opposite camp. I think this is one of the best features added to WordPress in a long time. The only thing better would have been to remove the new plugin/theme editor completely by default, and requiring a constant manually set in wp-config.php to enable it. (Well, that and limiting the plugin/theme editor to only edit CSS/JS files.)

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    I’ve removed the tag “4.9 sucks”. Please don’t do that, OK?

    Unable to communicate back with site to check for fatal errors, so the PHP change was reverted. You will need to upload your PHP file change by some other means, such as by using SFTP.

    Something isn’t working on your setups. Are you willing to work with us to sort it out? We’ll need some info about your setup to try and figure out if other people can make it fail for them the same way it’s failing for you.

    If your error can be reproduced then it’s possible a fix can be created to help you and others who are having this issue.

    What version of PHP are you running?

    b747fp

    (@b747fp)

    If this feature is a “debug” feature, why is it ignoring the WP_DEBUG=false setting in wp-config?

    I am using PHP 5.6, this occurs on both Cpanel and non-Cpanel servers. I cannot edit any theme PHP files on any of my sites since 4.9 released. I use Installatron to keep my WP version and Plugins current, so naturally they all upgraded to 4.9 and now I can’t make changes to any of them without FTP.

    My ability to edit my theme’s files (themes that work perfectly fine, btw) should not be determined by 3rd party plugins’ problems. It has essentially rendered the theme editor completely useless as a WP admin, which is a big step backwards.

    This still occurs if i try changing to PHP 7 also, so i dont know that it’s a PHP version issue.

    For now I will probably revert back to WP 4.8.x until some new release provides a fix or workaround or starts obeying WP_DEBUG=false

    williampatton

    (@williampatton)

    I have fixed the unable to communicate back with the site message several times and it was caused by the hosting panel not setting up the hostname of the container or VM to match the domain name.

    The hostname should either match the domainname or it should use the hosts file to map the domain name back to the local host.

    Perhaps this is the same issue you are facing with your sites?

    The same issue can be observed by installing this plugin: https://wordpress.org/plugins/wp-crontrol/ and then visiting it’s settings page where you will see a message along the lines of ‘WP_Cron is not running correctly’.

    • This reply was modified 1 year ago by  williampatton. Reason: extra testing info for after revert
    kjodle

    (@kjodle)

    Agreed, something isn’t working on your setups. Why are you editing theme files constantly anyway? Your best bet for modification is always a child theme, which you can develop in localhost, and then upload once and activate. Perhaps a better workflow would solve a lot of problems for you.

    The only thing better would have been to remove the new plugin/theme editor completely by default, and requiring a constant manually set in wp-config.php to enable it.

    I’d upvote that!

    I’ll just install a real file manager plugin like https://wordpress.org/plugins/wp-file-manager/ because it actually works.

    The only thing better would have been to remove the new plugin/theme editor completely by default, and requiring a constant manually set in wp-config.php to enable it.

    Oh yes, please do remove the editor becuase it is now worthless. It’s not related to my hosting, it is happening on any host i’ve tried to edit site files on since 4.9 was introduced.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘4.9 problems’ is closed to new replies.