Support » Plugin: Contact Form 7 » 4.8 version doesn’t work

  • Resolved makspostal

    (@makspostal)


    Hi,

    After update CF till v.4.8 doesn’t work Submit button on all my websites anymore.

    Errors:
    jquery.js?ver=1.12.4:4 GET /wp-json/contact-form-7/v1/contact-forms/4/refill 404 (Not Found)
    POST /wp-json/contact-form-7/v1/contact-forms/4/feedback 404 (Not Found)

    Tell please, how to fix it?

    • This topic was modified 2 years, 4 months ago by  makspostal.
Viewing 10 replies - 31 through 40 (of 40 total)
  • Hi Chris,

    Do you use any code in function.php for disable REST API?

    I have tried all solutions from this topic and they sometimes worked, but after update CF7 the problem had appeared again.
    I had remove all rest api code from function.php, so now I don’t have any issues.

    Petr

    (@csclubtauranga)

    Hi guys,

    I’ve also found that when the /contact-form-7/includes/js/scripts.js file is getting pulled by my CDN, I’m unable to get it to work, even after purging the script. So by precluding the script to get handled by CDN in the first place I’ve resolved the issue on my site.

    Hope it helps.

    I had this problem too with v4.9. So to test I deleted the Contact 7 (v4.9) plugin folder and installed Contact 7 (v4.7). Everything was working again. Then I deleted the Contact 7 (v4.7) plugin folder and installed Contact 7 (v4.9) and everything started working again. Strange problem.

    I have the same problem :
    Failed to load resource: the server responded with a status of 404 (Not Found) /wp-json/contact-form-7/v1/contact-forms/7/feedback

    My 11 website are affected … need a fix !

    2 steps to solve this problem:

    1) Remove all plugins and code from functions.php that disable the REST API WordPress
    2) Go to site.com/wp-admin/options-permalink.php and push the button

    • This reply was modified 2 years, 1 month ago by  Seredniy.
    Thomas Villain

    (@anybodesign)

    thanks @seredniy, it solved my problem!

    cim

    (@cim)

    Here’s how I solved my issue. If you have a plugin or any code that blocks the WordPress REST API, then delete/disable it. The culprit for me was WordFence.

    Here’s a screenshot: https://i.imgur.com/I1pImC9.png

    If you’re running WordFence, just disable this option.

    Thanks genyus (@genyus), we had an IIS rewrite rule that added a trailing slash to the path. Removing this fixed the contact forms.

    If this can help anyone, I also suffered related issues with the same symptoms and it had to do with some CF7 custom validation rules for text fields I had setup in functions.php.
    One of them was not returning anything and that missing return statement was the culprit.

    Just recently had an issue with this as well. The culprit was the below plugin.
    https://wordpress.org/plugins/cimy-swift-smtp/

Viewing 10 replies - 31 through 40 (of 40 total)
  • The topic ‘4.8 version doesn’t work’ is closed to new replies.