Support » Fixing WordPress » 4.8 Bug in widgets with TinyMCE

  • Resolved ElectricFeet

    (@electricfeet)


    Hi there,
    I just updated to 4.8 on some of my sites and have come across what I think is a bug in the way the text/visual tabs work in TinyMCE in widgets.

    I have a footer widget which contains opening hours / address / tel info that is in structured data format, using something like this:

    <div itemscope itemtype="http://schema.org/LocalBusiness">
    <p itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"><span itemprop="streetAddress">blah blah</span>Etc Etc</p>
    <p>Tel:<span itemprop="telephone">12345678</span></p>
    </div>

    When I open the widget, I am taken into the “Visual” tab. This of course doesn’t show the structured data code.

    When I switch to the “Text” tab, the structured data is not shown.

    If I then replace the structured text with a backup and save it, all is well and it appears on the page…

    …But the next time I open the widget, I get taken to the “Visual” tab again, which loses the structured data again.

    Losing data between the “Visual” and “Text” tabs in pages/posts is a problem I’ve always had with TinyMCE, but on pages/posts it seems to remember which tab you prefer, allowing you to skip using the “Visual” tab altogether on those that have problematic code.

    It would be good if the problem were to be fixed completely (both for widgets and pages/posts).

    However, if it cannot be fixed (or is low priority), could we at least take the same approach for widgets as we take for pages/posts? That is: remember which tab I last used on each widget, and default to that tab when opening, so as not to lose data?

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘4.8 Bug in widgets with TinyMCE’ is closed to new replies.