Support » Fixing WordPress » 4.6.x Upgrade: Fatal error: Class ‘Requests_Hooks’ not found

  • I’ve been trying for a few hours to update from 4.5.3 to 4.6.1. Upon updating WordPress I’m getting a fatal error:

    Fatal error: Class 'Requests_Hooks' not found in /my/absolute/path/wp/wp-includes/class-http.php on line 307

    I have tried using the automatic updater, and manually updating. I’m seeing the same problems on 4.6.0 also. This error on numerous admin pages: /wp-admin/update-core.php /wp-admin/themes.php.

    Searching the net has only turned up with “Try downloading the files again”.. I’ve tried this.

    Anyone seeing this issue?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator t-p

    (@t-p)

    Try MANUALLY updating. Download a fresh copy of the WordPress .zip file to your computer, unzip it, and use that to copy up all files and folders EXCEPT the wp-config.php file and the /wp-content/ directory. You may need to delete the old wp-admin and wp-includes folders and files on your server before uploading the new ones. Please read the Manual Update directions first.

    Thread Starter EL45

    (@el45)

    Thank you for your response, as I’ve mentioned, I have tried manually updating multiple times. with both 4.6.1 and 4.6.0.

    Moderator t-p

    (@t-p)

    – Please check the error logs on your server for a more specific error message and see why it’s failing. If you need help locating them, ask your hosting provider to help you with that.

    I’m seeing the exact same issue on a site I manually upgraded.
    Does anyone know where Class ‘Requests_Hooks’ is supposed to be defined?

    Moderator t-p

    (@t-p)

    @youtag, If the troubleshooting already posted made no difference for you, then, for better results, as per the Forum Welcome, please post your own topic.

    Thanks @t-p. I was able to solve the problem by re-uploading all wordPress files. This time, I replaced the content of wp-admin and wp-includes folders rather than merging them with the new content.

    The error, in my case, was due to either some files not being uploaded properly the first time or to non-replaced files causing the conflict.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘4.6.x Upgrade: Fatal error: Class ‘Requests_Hooks’ not found’ is closed to new replies.