• gabrielhargitai

    (@gabrielhargitai)


    Just after the update it brought down the whole site:

    Uncaught TypeError: Argument 1 passed to WCML_Emails::__construct() must be an instance of woocommerce_wpml, null given, called in <site_dir>/wp-content/plugins/yith-woocommerce-request-a-quote-premium/includes/emails/class.yith-ywraq-multilingual-email.php on line 42 and defined in <site_dir>/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-emails.php:24 Stack trace: #0 <site_dir>/wp-content/plugins/yith-woocommerce-request-a-quote-premium/includes/emails/class.yith-ywraq-multilingual-email.php(42): WCML_Emails->__construct(NULL, Object(SitePress), Object(WooCommerce), Object(wpdb)) #1 <site_dir>/wp-content/plugins/yith-woocommerce-request-a-quote-premium/includes/emails/class.yith-ywraq-multilingual-email.php(74): YITH_YWRAQ_Multilingual_Email->__construct() #2 <site_dir>/wp-content/plugins/yith-woocommerce-request-a-quote-premium/includes/class.yith-request-quote-premium.php(154): require_once(‘<site_dir>…’) #3 /home/bor

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author sergey.r

    (@sergeyr-1)

    Hi gabrielhargitai,
    as I can see error comes from yith-woocommerce-request-a-quote-premium plugin.

    Can you please try de-activate it ( if it solve a problem please contact plugin author )?

    gabrielhargitai

    (@gabrielhargitai)

    Hi @sergeyr-1,

    That didn’t do the trick – somehow our license expired mid-update and one half of the WPML packages updated but other half did not. Renewing the license and doing the update by hand fixed this issue.
    Thanks for the fast reply!

    Cheers,
    Gabor

    Plugin Author sergey.r

    (@sergeyr-1)

    Nice to see that you fixed an issue!

    Maybe you can provide more info how it happened? Have you used our Installer?

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.