Support » Plugin: The Events Calendar » 4.6.1 to 4.6.2 upgrade broke my site

  • Resolved mhair

    (@mhair)


    This is the second (or possibly third) time an upgrade has broken my site. Think it’s time for some better QA. I reverted to 4.6.1 and the site worked properly. Was this function removed? The error was:

    Fatal error: Call to undefined function tribe_is_past() in c:\path here\theme-functions.php. Here is the relevant function.

    function tribe_past_reverse_chronological ($post_object) {
    $past_ajax = (defined( ‘DOING_AJAX’ ) && DOING_AJAX && $_REQUEST[‘tribe_event_display’] === ‘past’) ? true : false;
    if(tribe_is_past() || $past_ajax) {
    $post_object = array_reverse($post_object);
    }
    return $post_object;
    }
    add_filter(‘the_posts’, ‘tribe_past_reverse_chronological’, 100);

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.