WooCommerce SagePay Direct Payment Gateway
[resolved] 3d secure not working (8 posts)

  1. Glovebox123
    Posted 3 years ago #

    We are getting a 404 error when the payment page goes to 3d secure. I have checked with sagepay and they said that the request went as far as asking for the 3d secure password but goes no further.

    Can anyone help please.



  2. swicks
    Plugin Author

    Posted 3 years ago #


    When you 'Place order' with all the fields populated - the Checkout -> Pay page is displayed with a frame showing a 404 error.

    The page it's trying to display is the ACSURL (generated by SagePay)
    Are you trying this in Test mode with debug set to an email address?
    Would be interesting to see what's in the response (email).



  3. Glovebox123
    Posted 3 years ago #

    Hi Steve
    Thanks for replying. It is inside the iframe the 404 loads up.

    This is the test mode reply:

    Payment Gateway URL: https://test.sagepay.com/gateway/service/vspdirect-register.vsp

    3D Secure Callback URL: https://test.sagepay.com/gateway/service/direct3dcallback.vsp

    Payment Gateway Response:Array
    [VendorTxCode] => par*****p-130731182317-146189692
    [Created] => 2013-07-31 18:23:18
    [VPSProtocol] => 2.23
    [Status] => 3DAUTH
    [StatusDetail] => 2007 : Please redirect your customer to the ACSURL, passing the MD and PaReq.
    [3DSecureStatus] => OK
    [MD] => 20137529499754790625
    [ACSURL] => https://test.sagepay.com/mpitools/accesscontroler?action=pareq
    [PAReq] => eJxVUstuwjAQvPcrIj4ga+dJ0GJEi9pGpVUorVCPlmNBVPLASRr4+9qQQHubGe2Od2eNs2O+t36kqrOymI6oTUYzdocfOyXlYi1FqyTDV1nXfCutLJ2OHELd0HciL4pC3wsjEjj+iGEyf5cHhr0R0z42RRiodlBix4uGIReH+/iNeWTsuw5CTzGXKl4w3yOeG/jEo2FAHB/hImPBc8kSrr63vJFPqmwrhLOGomyLRp3Y2AkQBoKt2rNd01QTgK7r7Krv3JpOW5Q5gqlAuI2VtAbV2vGYpWxzcFdLsowfg7LtNpvlqh7DfMW/XuBzimAqMNV+zIRBQpdaNJo47oSGCGcdeW5GYTqCHmFlHphf5b8UdcpKFmLYYmAoj1VZSF2hg7piTGUt2NrcI+En6zWJ9aNGQrgt8fBskhaNDs/McEHGL9Px0ICEZ0NDEEwt9PeD/tQa/fsCv9sVtI0=
    [result] => success
    [redirect] => http://www.****.co.uk/checkout/pay/?key=order_51f956159c75b&order=8740

  4. swicks
    Plugin Author

    Posted 3 years ago #

    The debug data looks ok.

    The process is:

    1. SagePay sends a 3DAUTH status
    2. This is handled by the gateway and redirected to woocommerce 'pay' page.
    3. an action will trigger the auth_3dsecure function within the gateway - if iframe is enabled it will load pages/3DRedirect.php which will then fires a javascript OnLoadEvent to submit the form with the ACSURL information provided by SagePay.

    try without custom permlinks.
    Check that javascript & iframes are enabled.
    what browsers have you tried?

    hope this helps.



  5. Glovebox123
    Posted 3 years ago #

    Hi Steve
    I have checked and iframes are working as we have product video's working ok on some products. Javascript is ok. I had tried Chrome and IE with the same result except with IE the 404 page loads without any css. Is there some way I can chat with you about this to get a resolution, it is not a problem if we need to pay.

  6. swicks
    Plugin Author

    Posted 3 years ago #

    Hi Adam

    You can contact me via support(at)devicesoftware.com

    Do you get a tomcat 500 error clicking on ACSURL link? (you should because it's expecting some POST data)

    Do orders get processed if you disable 3DSecure through MySagePay (Test)?

    In Chrome add your payment details and before you press 'Place order' open 'Developer Tools' (F12 on windows) and disable javascript (settings icon - bottom right) - hopefully you won't see a 404 but a 'Go' submit button - right click on the button and view frame source - keep this and go back to the checkout page and click on the 'Go' button - if you get a 404 check the forms action url is identical to the ACSURL.

    What versions of WooCommerce, WordPress and the SagePay payment gateway are you using?

    Did you try removing your custom permlinks? (this is unlikely as the redirect link is used after the ACSURL)

  7. swicks
    Plugin Author

    Posted 3 years ago #

    FYI: This issue was resolved by setting the correct permissions on the WordPress plugins folder.



  8. Glovebox123
    Posted 3 years ago #

    It was, thanks again for your help Steve.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic


No tags yet.