• My client’site uses WordPress 3.8.1, WooCommerce 2.0.20 and WooCommerce SagePay Direct Payment Gateway After entering the credit or debit card details, a customer will reach the WooCommerce Pay page, but that’s it. There is no confirm payment button or redirect to the 3DAuth page. SagePay then declines the payment as there is no response to the 3D Auth request after 15 minutes.

    I have the following pages with shortcodes set up in the site:
    Checkout – [woocommerce_checkout]
    – Checkout -> Pay – [woocommerce_pay]
    – Order Received – [woocommerce_thankyou]

    Customers don’t get to the thank you page. As this client is a florist, and Friday is Valentine’s Day, this matter is fully urgent.




Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author swicks



    The versions you are using do work together – The current version of SagePay hasn’t been tested fuly on WC2.1 yet, but will be very soon.

    Have you had this site working with previous versions (if so what versions?) or is this a new install?

    In ‘test’ mode with debug enabled what results do you get in the logs?




    I am unaware of whether this worked previously as I have just taken over the site.

    In the TEST environment I get the following debug email info:

    Payment Gateway URL: https://test.sagepay.com/gateway/service/vspdirect-register.vsp

    3D Secure Callback URL: https://test.sagepay.com/gateway/service/direct3dcallback.vsp

    Payment Gateway Response:Array
    [VendorTxCode] => d****************8
    [Created] => 2014-02-12 12:28:16
    [VPSProtocol] => 2.23
    [Status] => NOTAUTHED
    [StatusDetail] => 2000 : The Authorisation was Declined by the bank.
    [VPSTxId] => {A************9}
    [SecurityKey] => **********
    [AddressResult] => NOTPROVIDED
    [PostCodeResult] => NOTPROVIDED
    [CV2Result] => NOTPROVIDED
    [3DSecureStatus] => NOTCHECKED
    [result] => notauthed

    I have starred out the ids. Let me know if they are needed.

    However, when i test it on LIVE, the transaction goes through as I stated in my original post, and the status detail in WooCommerce is stuck on Contacting bank for authorization. (Code: 2007 )

    We have also spoken to SagePay and they have said that we need to ensure we are directing the customer to the acs url and are submitting md and pareq. They also said we should be using form integration rather than direct integration.

    I have also notice that the force secure checkout option is not ticked. Is this needed for SagePay?

    Plugin Author swicks


    You can’t use this gateway with form or server integration, it has to be direct – please confirm with Sagepay.

    When you go live you must have a valid ssl certificate and force secure option should be checked and you would require PCI DSS certification.




    The direct issue is unrelated to the 3D AUTH issue. It is about something else.

    So will setting force secure to true fix this issue?

    Plugin Author swicks


    Force secure is not required for simulator or test, but is required for live with 3DAuth, whether it will resolve your issue, I’m unsure.

    You do need Sagepay to confirm that Direct is setup on test & live and the banks have enabled 3DAuth on their side (normally VISA & MasterCard).

    Has 3DAuth been setup in the test & live VSP Admins?



    I’m getting a similar problem where I fill in the details on the checkout screen, submit the order. The little ajax spinner spins round to indicate some action but then instead of loading up the 3D secure bank iframe where normally I would enter my 3D secure password, it redirects me to the following URL (or similar):


    I’m not aware of anything that’s been changed on the site apart from maybe upgrading WordPress core and possibly your plugin. I’ll conduct some further debugging to try and figure out what is happening.

    I downgraded the plugin to This solved the problem. For some reason the participating bank (3d secure) iframe isn’t being rendered in the latest version of the plugin. I am running WooCommerce 2.0.12

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘3D AUTH’ is closed to new replies.