WordPress.org

Forums

Stargazer
[closed] 3.9 only (8 posts)

  1. zota
    Member
    Posted 1 year ago #

    Version 1.1.0 gives fatal errors for WordPress prior to 3.9. The developer said that not calling functions without checking if they exist is not a bug, but a deliberate choice.

    Use at your own risk.

  2. Justin Tadlock

    Theme Author

    Posted 1 year ago #

    Just to be clear to those who are reading the above review, the reviewer is using an old version of WordPress and gave a 1-star review because the theme is using the most up-to-date WordPress standards rather than old functionality.

    Use old versions of WordPress at your own risk. Otherwise, enjoy the theme.

  3. zota
    Member
    Posted 1 year ago #

    As further clarification, I was running a version of WordPress (3.8.3) which was released less than a month ago.

    The reason I gave this theme a two-star review is because the 1.1.0 update does not document that it is 3.9 only, the code does not wrap some of it's function calls to ensure they exist, and rather than gracefully degrading when a feature is unavailable, it simply breaks the site.

    I took off an additional star because throwing an unnecessary fatal error in last month's version of WordPress is apparently not even seen as a bug.

  4. Justin Tadlock

    Theme Author

    Posted 1 year ago #

    The reason I gave this theme a two-star review is because the 1.1.0 update does not document that it is 3.9 only,

    WordPress.org provides no mechanism for letting users know which versions of a theme support which WordPress version (it does with plugins). This is a failure on WordPress.org's part. I can't personally do anything about that.

    This would be the correct place to address that issue:
    https://meta.trac.wordpress.org/ticket/215

    the code does not wrap some of it's function calls to ensure they exist, and rather than gracefully degrading when a feature is unavailable, it simply breaks the site.

    The new version is not compatible with old versions of WordPress. Users can always use an old version of the theme if they wish to use an old version of WordPress.

    I took off an additional star because throwing an unnecessary fatal error in last month's version of WordPress is apparently not even seen as a bug.

    It is not a bug.

  5. zota
    Member
    Posted 1 year ago #

    It is not a bug.

    [Link removed]

  6. Justin Tadlock

    Theme Author

    Posted 1 year ago #

    That'd be a difference in development philosophy. It's still not a bug. I explained all of this to you in an email already.

  7. zota
    Member
    Posted 1 year ago #

    As I stated in my review, I understand that you do not believe this is a bug. This is a difference in philosophy, which I feel I've stated fairly.

    I agree that new theme features should not be supported in old versions of WordPress. Our disagreement is that I do not think a theme update should fatally break a site running a ten-day old version of WordPress.

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    I have just downloaded & activated this theme on a WP 3.9 site without the slightest problem. So whatever your issue is, it is specific to your site. All themes submitted to - and updated on - wordpress.org are subjected to an extensive quality review which includes running the theme on a site using the latest version of WordPress. If you chose to use an older version of WordPress (and, therefore, are happy to run the increased risk of your site being hacked), do not blame the theme for your poor choices.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.