WordPress.org

Support

Support » Alpha/Beta » [Resolved] 3.9-beta1: No [wordpress_adv_hidden] in tiny_mce_before_init Filter

[Resolved] 3.9-beta1: No [wordpress_adv_hidden] in tiny_mce_before_init Filter

  • 3.9 Beta 1 no longer passes array element ‘wordpress_adv_hidden’ in the first argument ($mceInit array) of the Filter ‘tiny_mce_before_init’.

    Despite lots of searches, I could not find that fact mentioned anywhere, so was not sure if that is intentional or a bug. Before I run off and rewrite my plugin (jonradio Display Kitchen Sink), I wanted to check. I’m happy to report it to Trac, but wanted to be sure I hadn’t missed something.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Oops, I better do a little more research. ‘wordpress_adv_hidden’ was not provided in previous versions either. But, if you added it, you could turn the kitchen sink on or off, depending on its setting.

    The JavaScript that processes it is all new, so I’ll check it out.

    @jonradio, did you ever find anything? I’ve been looking for the same thing and come up empty.

    You can see a working example in Version 3 of http://wordpress.org/plugins/jonradio-display-kitchen-sink/

    The only reliable way that I found to control Kitchen Sink is with the hidetb setting, but it has to be set in both the database and the cookie.

    It took a lot of work to come up with a way to make it work all the time, so you may want to explore using the plugin, as it also supports older WordPress versions.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] 3.9-beta1: No [wordpress_adv_hidden] in tiny_mce_before_init Filter’ is closed to new replies.