WordPress.org

Forums

[resolved] 3.9 Beta 1 Thumb-less images block gallery (6 posts)

  1. Laurens Offereins
    Member
    Posted 1 year ago #

    Images that do not have any other file size then their original upload size (so without any thumbs) block the creation of a gallery. So although the media modal recognizes them and you can select them to put in a gallery, hitting 'insert gallery' fails silently with a Uncaught TypeError: Cannot read property 'url' of undefined error in the console and an empty post editor. I am not sure whether this was already the case before.

  2. How are you making images without thumbs? By default WP makes a thumbnail unless upload has totally failed, which SHOULD throw an httpd error at the very least.

  3. Laurens Offereins
    Member
    Posted 1 year ago #

    I was wondering that myself too. It may be due to do an incorrect import/move from another installation. That was a long time ago though, so I cannot find out how that happened. Still, wouldn't you consider this to be a case worth looking at? Perhaps solve it with checking for existence of thumbs before selecting an image in a gallery?

  4. I think it's kind of an edge case, as it was a long time ago and now WP will fail before adding an image to the library at all. I don't know how we'd reproduce it anymore.

  5. Laurens Offereins
    Member
    Posted 1 year ago #

    Yes, I too found that the Text tab showed the shortcode correctly, but the Visual tab wasn't successful in showing the gallery view.

    Thanks for your support!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags