WordPress.org

Support

Support » How-To and Troubleshooting » 3.8.1 Update – Image library and media uploader not working (in posts only)

3.8.1 Update – Image library and media uploader not working (in posts only)

  • Here’s my issue: Last week on Thursday, my site was running normally. Thursday night, my web designer installed a new custom theme. Friday, I upgraded to 3.8.1. Now, when I click the media button inside of a post or a page, the Library is blank. No images appear, nor do any show up when I search. When I try to upload an issue, I get an error that just says “An Error occurred in the upload. Please try again later.” HOWEVER, if I open my Media library from the main dashboard all of the images appear, and it shows that any images I’ve tried and received the error on have, in fact, successfully uploaded.

    Here’s my site: http://diydiva.net

    Here’s what I’ve tried (in conjunction with my web designer):
    – Deactivated all plugins: no change
    – Reverted to default 2014 theme: no change
    – Restored to 3.8 through GoDaddy: no change

    I’ve read about issues with 3.8.1 relating to image size or relating to specific plugins, but those don’t seem to be my problem. I’m only about 30% literate at things relating to code and I do rely on GoDaddy for WP updates, etc. But I am familiar with accessing the files via FTP and editing if I know exactly what to look for.

    Anyone have any ideas on what I should try next?

Viewing 15 replies - 1 through 15 (of 34 total)
  • There seem to be a variety of different issues related to 3.8.1 updates. Though the symptoms vary, the common denominator seems to be some sort of database corruption. You can find what worked for me in this thread:
    https://wordpress.org/support/topic/no-dimensions-for-new-images-3?replies=10
    Or maybe have your dev poke around in the database.
    I enjoyed your site by the way – I live in a building that barely merits the title “house” (1876), and also have a cat with “species issues”.

    Thank you so much! I was actually looking at that post earlier… wondering if you can give me just a little bit more info.

    I’m getting the gist of the meta-data on images being corrupted (is there any way to confirm this other than running the plugin suggested in that thread?)

    I don’t fully understand once I run the plugin what/why I would need to rebuild thumbnails or what that means exactly. Would love to have just a little more info/understanding about what is going to happen before I start pushing buttons.

    Also, if there’s some overall database corruption, does this basically solve it, or is there something I would need to do with the actual database?

    (^I’m writing all kinds of words here, but I only really understand what half of them mean.)

    In my case, thumbnails didn’t generate for a bunch of images all uploaded at the same time by another user. I noticed the update to 3.8.1 happened the same day which made me suspect that was the cause but I can’t say if the upload just went wrong or the update broke something.
    If you can see the thumbs when you open the media library and they appear in the insert image dialog in the page editor (with all available sizes), you may have a different problem. But it seems mighty coincidental that so many people are experiencing a variety of problems with images, right after the update.
    The plug in suggested in that thread is “harmless” and ostensibly only tries to repair image meta data. The only other thing I did was delete all the affected images. Unless someone else has another idea, and as long as you do a back up before using it, I’d say give it a whirl.
    And let us know if it works.

    Ah, nope, no good. I ran both this plugin: https://github.com/WPRanger/wpr-rebuild-meta-data/

    And this one: Force Regenerate Thumbnails

    Still having the same problem. This is a little bit infuriating.

    If you enter an image url in the browser, does it open? When you upload to the media library, does the “crunching” progress bar complete?
    Do you see all the different sized versions of uploaded images when you go to the uploads folder from your cpanel’s file manager (or ftp)?
    Next you may have to consider reuploading the wp-admin and wp-includes directories from a fresh download.

    Has anyone resolved this issue as yet? I have run the plug-in scripts from above but they do not fix the issue of blank images. I will continue to research this issue and post back what I find.

    if you have changed the permissions to your upload folder, try then changing the name of the image that you want to upload and then re-upload it! I had the same issues…I began to remedy the issue by the following methods:

    I tried to use the plug-in method as listed above but this didn’t seem to work. I changed the permissions on my uploads folder to 777, then I unchecked the option to have my uploads sorted into files and folders in settings>media. I also amended the thumbnail sizes in settings>media saved the settings and then changed them back.

    I then renamed the images I wanted to upload and the images began appearing.

    I know that this will not help with images already uploaded but I am looking into that now….hope this helps someone out!

    I have had the same issue but I uploaded the plugin WP ERROR FIX & it resolved the issue for me…a great plugin for internal errors..

    Has anyone resolved this? I am running 3.8.1 and nothing happens when I click on Add Media in Posts or Products (Woocommerce).

    I have tried changing theme, disabling/enabling all plugins. Nothing.

    WP Error Fix detected nothing.

    Hi everyone,

    I am new to wordpress and I am trying to get a blog post together and time so that it is ready by the morning. My “Add Media” button in my saved draft is not working but I have already uploaded the images I want to put in the post to the library.

    It’s just that when I click on the “Add Media” button its like you all said. Nothing happened. I have also deactivated my plugins, went back to the 2014 wordpress theme, and I even reinstalled 3.8.1

    I don’t know what to do?

    I also don’t know how to start new threads to ask other questions.

    Please help,
    Marisa

    Marisa,
    The meta rebuild plug in that’s worked for me everytime (on multiple sites) has disappeared itself now, so try the WP Error plug in mentioned above.
    By the way, this happens everytime I update WP to 3.8.1 so it’s definitely a bug though not officially acknowledged as such, as far as I know – has anyone heard word when it’s going to be fixed?

    Thank you very much for answering me so quickly! I will try that!

    The plug-in said that there are no errors. I am sure another solution was already given if this should happen but, as I said, I am very very new to wordpress. As a fashion blogger, I could tell you the history of the bob haircut but I don’t know anything about codes and that sort of thing. So thank you to anyone who reads this for your patience.

    Since the WP Error Fix plug-in did not register the “Add Media” button not doing anything when I click on it, what should I try next?

    In my case, after updating to 3.8.1, the insert media box opens but images aren’t getting crunched when uploaded, so there’s only 1 size available. Also thumbs are of course missing from the media library. Are you able to upload images?

    Yes, I can upload the images to the library but when I click “Add Media” that little window that shows me my photos doesn’t pop up. I can also go to my media library and see all my pictures perfectly fine.

    I am using a Macbook Air and my browser is Safari. I don’t know if that helps identify the issue. Is there any other info that I may not be giving that might help? I hope I’m explaining it right!

Viewing 15 replies - 1 through 15 (of 34 total)
  • The topic ‘3.8.1 Update – Image library and media uploader not working (in posts only)’ is closed to new replies.