WordPress.org

Support

Support » Plugins and Hacks » 3.8 Update – Be Cautious

3.8 Update – Be Cautious

  • I am releasing 3.8 as there are a couple of people waiting for some features they requested.

    However this is a significant update. A LOT of stuff changed “under the covers”. I got very little help from the beta group in testing this release (I saw no “good/no good” reports). I did basic testing but was sick for a week and preparing for family holiday travel.

    I *THINK* 3.8 is production ready, but you really should test this release in your environment first if at all possible.

    If you have issues please report them here and I will try to address any newly introduced bugs quickly.

    Happy Holidays everyone!

    – LC

    http://wordpress.org/extend/plugins/store-locator-le/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Just updated the plugin to 3.8 and I received the following error in the top of the WordPress admin window:

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, first array member is not a valid class name or object in /path/to/wp-includes/plugin.php on line 406

    Deactivated the plugin and I no longer see the error. I did not see this error before applying the update to 3.8.

    Plugin Author Store Locator Plus

    @charlestonsw

    @salty-sailor – I just did a clean install of SLP 3.8 on WP 3.5 and cannot reproduce that message.

    Do you have any add-on packs enabled for SLP? What version of WordPress are you using?

    Maybe I’m a ‘tard.
    I guess I’m not talking about “Store Locator Plus” but instead I’m talking about “Google Maps via Store Locator Plus”. The installation is on:
    WordPress 3.5, network installation
    I don’t have “Store Locator Plus” installed! I was not aware there were add-on packs and don’t have any installed.

    Interesting update. I deactivated the plugin at the Network Admin panel, activated in the subsite panel, and no more error message.

    Plugin Author Store Locator Plus

    @charlestonsw

    Very odd. I was able to generate an intermittent warning message that stopped one of my test sites from loading the plugin. I’m releasing a patch in 3.8.1 that seems to fix this, but I have no idea why WordPress 3.5 MU seems to have an issue in some cases. I’ve checked the plugin code 5x and there is no reason the variable that is generating the warning should ever be un-set that early in the process..

    3.8.1 is doing a test that should not be necessary. Hopefully it resolves the issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘3.8 Update – Be Cautious’ is closed to new replies.