WordPress.org

Forums

[resolved] 3.8 /post count via meta issues? - library not showing, single.php, blankscreens (16 posts)

  1. Fountain Mountain
    Member
    Posted 2 years ago #

    Hi there,

    I just updated to 3.8 earlier today, and have been having major issues. wp-admin will not open (not even for the login page) in chrome/ie. Instead it opens a completely blank page.

    It opens/works ok in firefox, but there are some issues.

    The library is showing when you click on it in the side menu, but when you are adding images within posts, there appear to be none in the library. If you upload one, then it does that ok, but when you click 'insert into post' it doesnt appear within the post at all.

    Plus everytime you update anything, even a post, you end up on a completely blank page.

    Is there issues with this update? Are these problems happening to others? I remember having a similar issue (going to blank pages after editing) some time back and having to perform a manual install. That was an issue that thousands of other webmasters had at the time. Im not sure what it was, I just remember that.

    Prior to upgrading to 3.8, everything seemed fine. There were no blank screens as far as i remember. However, I did make one other change, yesterday, I added post view counts via meta, not a plugin...

    First I added the following to functions.php in my theme...

    <?php
    
    remove_action('wp_head', 'start_post_rel_link', 10, 0 );
    remove_action('wp_head', 'adjacent_posts_rel_link', 10, 0);
    
    // function to count views.
    function setPostViews($postID) {
        $count_key = 'post_views_count';
        $count = get_post_meta($postID, $count_key, true);
        if($count==''){
            $count = 0;
            delete_post_meta($postID, $count_key);
            add_post_meta($postID, $count_key, '0');
        }else{
            $count++;
            update_post_meta($postID, $count_key, $count);
        }
    }

    then i added this to line 1 of my single.php

    <?php setPostViews(get_the_ID()); ?>

    and finally I added this to my single.php where i wanted post counts to appear

    <?php echo getPostViews(get_the_ID()); ?>

    That code is the final code, but I did make adjustments, because it initially caused conflictions, with the single.php failing to load within content for some people. I added a few blank spaces or empty lines, or moved the code to the very beginning or end of the files, and that seemed to fix it.

    Any ideas on what might be going on with my wp-admin?

  2. bryan.MCS
    Member
    Posted 2 years ago #

    i am having the same problems as of today. and i have not changed anything since yesterday. i don't even know if i may have been autoupdated because i cannot see my dashboard... the login page leads to nothing.
    *frustrated*

  3. Fountain Mountain
    Member
    Posted 2 years ago #

    ok, so its not just me!

    there is also this post just added too:
    http://wordpress.org/support/topic/38-after-update-wp-admin-gives-a-404-error-on-most-brosers?replies=1

    I think this could be the same issue as mine. I updated the core in Firefox, and thats the browser that actually (semi) works for me! The others don't, just like the user in that other post I linked.

    PLUGINS: I have turned them all off, and that did not fix the issue!

    WEBSITE: http://www.frg.ie

  4. WPyogi
    Forum Moderator
    Posted 2 years ago #

    I'd suggest using FTP to rename the plugins folder on the server and also switch to a default theme - to see if that resolves the problem. If so, reverse your steps one by one to find out what's causing the problem.

  5. Fountain Mountain
    Member
    Posted 2 years ago #

    I would delete my post inside that other thread, but I cant find any delete function. Feel free to delete it if you are able to. I understand what you are saying! If thats how you do it, then so be it. Even if it is completely counter-intuitive (towards spotting trends, and creating dialogue).

    Regarding my problem, which appears to be similar to the others, you got it spot on!

    I renamed the plugin folder, no change, but when I switched to the 2014 theme, it was fixed. So, its my theme. Aw shoooot. Ive messed with the code on that so much that i wouldn't know where to even begin.

    Is there any advice you have on this? I think I should just revert to 3.7. I did back it up earlier today.

    Thanks for the help WPyogi.

  6. WPyogi
    Forum Moderator
    Posted 2 years ago #

    Don't worry about it - it happens...

    As to your theme, that's going to be a tough one here - as commercial themes aren't supported on these forums AND you've modified it. You could enable debugging to see what you get -

    http://codex.wordpress.org/Debugging_in_WordPress

    BTW, using an outdated version of WP really isn't a good solution - as it's a significant security risk so you probably don't want to go that way.

  7. Regarding my problem, which appears to be similar to the others, you got it spot on!

    I renamed the plugin folder, no change, but when I switched to the 2014 theme, it was fixed. So, its my theme.

    Now that makes me happy. Not you having a problem but your walking through the steps/suggestions that WPyogi provided and you found where the problem was. ;)

    Is there any advice you have on this? I think I should just revert to 3.7. I did back it up earlier today.

    I'm sorry about your theme. Which theme is it? Perhaps the author will update it. Try contacting them and they may have a fix.

    Good job on that backup BTW. If you do decide to restore back to the previous version (that's not recommended but understandable sometimes) that backup of your files and database are the best safety net you can have.

  8. We actually keep track of all the similar posts :)

    I would try turning on WP_DEBUG (in your wp-config.php, change false to true) and see if you can get an actual error to pop up.

  9. Fountain Mountain
    Member
    Posted 2 years ago #

    Thanks again WPyogi, Ive tied that debugging, but I dont understand the code....

    [13-Dec-2013 01:53:21] PHP Deprecated:  Assigning the return value of new by reference is deprecated in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/plugins/audio-player/audio-player.php on line 903
    [13-Dec-2013 01:53:21] PHP Notice:  Undefined index: HTTPS in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/plugins/audio-player/audio-player.php on line 127
    [13-Dec-2013 01:53:21] PHP Notice:  Undefined index: SERVER_PORT_SECURE in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/plugins/audio-player/audio-player.php on line 127
    [13-Dec-2013 01:53:21] PHP Notice:  Undefined index: page in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/plugins/optimize-db/optimize-db.php on line 76
    [13-Dec-2013 01:53:21] PHP Deprecated:  Function eregi() is deprecated in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/plugins/optimize-db/optimize-db.php on line 76
    [13-Dec-2013 01:53:21] PHP Notice:  class-snoopy.php is <strong>deprecated</strong> since version 3.0! Use wp-includes/http.php instead. in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-includes/functions.php on line 2955
    [13-Dec-2013 01:53:21] PHP Notice:  get_current_theme is <strong>deprecated</strong> since version 3.4! Use wp_get_theme() instead. in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-includes/functions.php on line 2908
    [13-Dec-2013 01:53:21] PHP Notice:  add_custom_background is <strong>deprecated</strong> since version 3.4! Use add_theme_support( 'custom-background', $args ) instead. in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-includes/functions.php on line 2908
    [13-Dec-2013 01:53:21] PHP Notice:  get_bloginfo was called with an argument that is <strong>deprecated</strong> since version 2.2! The <code>home</code> option is deprecated for the family of <code>bloginfo()</code> functions. Use the <code>url</code> option instead. in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-includes/functions.php on line 3006
    [13-Dec-2013 01:53:21] PHP Notice:  get_bloginfo was called with an argument that is <strong>deprecated</strong> since version 2.2! The <code>siteurl</code> option is deprecated for the family of <code>bloginfo()</code> functions. Use the <code>url</code> option instead. in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-includes/functions.php on line 3006
    [13-Dec-2013 01:53:21] PHP Notice:  Undefined index: p in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/themes/newswire/functions.php on line 109
    [13-Dec-2013 01:53:21] PHP Notice:  Undefined index: p in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/themes/newswire/functions.php on line 109
    [13-Dec-2013 01:53:21] PHP Notice:  Undefined index: p in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/themes/newswire/functions.php on line 109
    [13-Dec-2013 01:53:21] PHP Notice:  Undefined index: p in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/themes/newswire/functions.php on line 109
    [13-Dec-2013 01:53:21] PHP Notice:  Undefined index: p in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/themes/newswire/functions.php on line 109
    [13-Dec-2013 01:53:21] PHP Notice:  Undefined index: p in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/themes/newswire/functions.php on line 109
    [13-Dec-2013 01:53:21] PHP Notice:  Undefined index: p in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/themes/newswire/functions.php on line 109
    [13-Dec-2013 01:53:22] PHP Notice:  Undefined index: p in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/themes/newswire/functions.php on line 109
    [13-Dec-2013 01:53:22] PHP Notice:  Undefined index: p in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/themes/newswire/functions.php on line 109
    [13-Dec-2013 01:53:22] PHP Notice:  Undefined index: p in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/themes/newswire/functions.php on line 109
    [13-Dec-2013 01:53:22] PHP Notice:  Undefined index: p in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/themes/newswire/functions.php on line 109
    [13-Dec-2013 01:53:22] PHP Notice:  Undefined index: p in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/themes/newswire/functions.php on line 109
    [13-Dec-2013 01:53:22] PHP Notice:  Undefined index: p in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/themes/newswire/functions.php on line 109
    [13-Dec-2013 01:53:22] PHP Notice:  Undefined index: p in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/themes/newswire/functions.php on line 109
    [13-Dec-2013 01:53:22] PHP Notice:  Undefined index: p in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/themes/newswire/functions.php on line 109
    [13-Dec-2013 01:53:22] PHP Notice:  get_bloginfo was called with an argument that is <strong>deprecated</strong> since version 2.2! The <code>home</code> option is deprecated for the family of <code>bloginfo()</code> functions. Use the <code>url</code> option instead. in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-includes/functions.php on line 3006
    [13-Dec-2013 01:53:24] PHP Deprecated:  Assigning the return value of new by reference is deprecated in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/plugins/audio-player/audio-player.php on line 903
    [13-Dec-2013 01:53:24] PHP Notice:  Undefined index: HTTPS in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/plugins/audio-player/audio-player.php on line 127
    [13-Dec-2013 01:53:24] PHP Notice:  Undefined index: SERVER_PORT_SECURE in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/plugins/audio-player/audio-player.php on line 127
    [13-Dec-2013 01:53:24] PHP Notice:  Undefined index: page in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/plugins/optimize-db/optimize-db.php on line 76
    [13-Dec-2013 01:53:24] PHP Deprecated:  Function eregi() is deprecated in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/plugins/optimize-db/optimize-db.php on line 76
    [13-Dec-2013 01:53:24] PHP Notice:  class-snoopy.php is <strong>deprecated</strong> since version 3.0! Use wp-includes/http.php instead. in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-includes/functions.php on line 2955
    [13-Dec-2013 01:53:24] PHP Notice:  get_current_theme is <strong>deprecated</strong> since version 3.4! Use wp_get_theme() instead. in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-includes/functions.php on line 2908
    [13-Dec-2013 01:53:24] PHP Notice:  add_custom_background is <strong>deprecated</strong> since version 3.4! Use add_theme_support( 'custom-background', $args ) instead. in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-includes/functions.php on line 2908

    seems like a lot of errors there?

    Hi Jan, we're using the newswire theme, but I have cutomised it a lot, and played with code quite a bit during the process. I'll send them a message and see of that helps! great idea!

    I hear you on the backup, I am sooo glad we done that today! It was because of the other issues (problems caused by adding post counts via meta) that we done it, otherwise, we would not have been so fortunate. phew :)

    Good to hear Mika! And how you do it it definitly has its plus points, but Im still 50/50 about it, although, you would know better than me as you actually are active within the system. I am slowly coming around from my initial thinking :)

  10. The main reason we do it is for YOU, not us, actually :) YOU get better help, rather than us trying to help everyone ;)

    [13-Dec-2013 01:53:22] PHP Notice:  Undefined index: p in /usr/local/pem/vhosts/127692/webspace/httpdocs/wp-content/themes/newswire/functions.php on line 109

    That looks the most suspect to me. WHat's on line 109 there?

  11. Fountain Mountain
    Member
    Posted 2 years ago #

    Fair play, thats a great spirit to have!

    I noticed that line 109 thingy... This is it here:

    if (strlen($_GET['p']) > 0) {

    the complete section of code it is contained within is this:

    # Limit Post
    function the_content_limit($max_char, $more_link_text = '', $stripteaser = 0, $more_file = '') {
        $content = get_the_content($more_link_text, $stripteaser, $more_file);
        $content = apply_filters('the_content', $content);
        $content = str_replace(']]>', ']]>', $content);
        $content = strip_tags($content);
    
       if (strlen($_GET['p']) > 0) {
          echo "";
          echo $content;
          echo " <a href='";
          the_permalink();
          echo "'>"."More »</a>";
          echo "";
       }
       else if ((strlen($content)>$max_char) && ($espacio = strpos($content, " ", $max_char ))) {
            $content = substr($content, 0, $espacio);
            $content = $content;
            echo "";
            echo $content;
            echo "...";
            echo " <a href='";
            the_permalink();
            echo "'>"."</a>";
            echo "";
       }
       else {
          echo "";
          echo $content;
          echo " <a href='";
          the_permalink();
          echo "'>"."Read More »</a>";
          echo "";
       }
    }

    is it saying i should take the 'p' out?

    p.s. Im not sure if this is relevant, or if that function even refers to this, but but we do not limit posts character amounts, or split posts over multiple pages.

  12. No, if you take $_GET['p'] out you have nothing to get. But... p is the variable p (see http://php.net/manual/en/reserved.variables.get.php) which is generally you post. And it's not something you'd see if you were using pretty-permalinks.

    Are you on the latest version of your theme?

    Have you asked thr theme dev? (I'm guessing it's this one http://www.theme-junkie.com/themes/newswire/ )

  13. Fountain Mountain
    Member
    Posted 2 years ago #

    That correct, that is the theme, but were not using the latest version. I think they are even on v2 and ours is v1, so we are probably a year out of date. Ive left a message on their forum, with the info I put above, including the debug results. Im awaiting a reply, they are usually pretty good, so hopefully soon!

    We didn't use a child theme, so its almost impossible to update it. There was a lot of messing with the code too.

    RE:p/permalinks

    I dont understand what you are saying tbh. Why would I not see it, if Im using pretty permalinks? And what permalinks do you mean? Im totally lost!

    Again, Im not sure if this is relevant, but there are absolutely no 'more »' or 'read more »' permalinked anywhere in our template. We only link the titles of posts and post images within archive.php, and the same on the homepage

  14. keighdesign
    Member
    Posted 2 years ago #

    I'm having similar issue. Updates to pages return a white page or return a NON-RESPONSE error. This began Dec 10 and is intermittent but happens more often than not. Doesn't seem to matter whether I'm on mac/pc or which browser (safari, firefox, chrome).

  15. esmi
    Forum Moderator
    Posted 2 years ago #

    @keighdesign: If you require assistance then, as per the Forum Welcome, please post your own topic.

  16. Fountain Mountain
    Member
    Posted 2 years ago #

    This now resolved. I had added some additional php to the functions.php, and enclosed it within its own php <brackets>. Once I amended all the php in that file into one piece of php code, it was fine!

    Thanks bryan.MCS, WPyogi, Jan and Mika for the help!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.