Support » Fixing WordPress » 3.7.1 update "Installation Failed"

  • This is pretty much breaking my brain at the moment. I’ve gone over the codex for installing WP, as well as the Master List and several posts with related issues that I came across, but I can’t put the finger on the cause of it.

    Downloading update from…

    Warning: touch() [function.touch]: Unable to create file /tmp/wordpress-3.tmp because No such file or directory in /home/author21/public_html/wp-admin/includes/file.php on line 155

    Warning: unlink(/tmp/wordpress-3.tmp) [function.unlink]: Operation not permitted in /home/author21/public_html/wp-admin/includes/file.php on line 479
    Download failed.: Could not open handle for fopen() to /tmp/wordpress-3.tmp

    I’ve gone over the files in question, though I can’t see any misconfigurations. I’ve validated permissions in question, but those are correct as well.

    What I do know is that it’s not theme related, or plugin related. The issue occurs regardless of theme, and both with and without plugins active (or even installed).

    Any suggestions would be more than welcome :/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator kmessinger


    Try adding
    define('WP_TEMP_DIR',ABSPATH.'wp-content/uploads/'); to your wp-config file. The install cannot find a temp directory.

    I’ll test it on a development copy of the site, thanks for the suggestion!

    If this is the root of the issue though, it would strike me as a bit strange – the install not being able to find a temp directory.

    Well I’ll be damned. That works as a workaround. Cheers kmessinger!

    I am curious though. I did test with the team’s plugin installed to check compatibility with automatic updates, and it gave a pass across the board.

    Any ideas as to where this issue comes from? Or how to prevent it in the future?

    Moderator kmessinger


    I think the server does not have write/read for the wp-content folder.
    You just defined a path to a folder that has write/read privileges.

    Hm, well I did check for that, and the permissions do check out for the wp-content folder.

    Strange. I did make sure to revert to default htaccess files as well, prior to the update, so it can’t be related to that either.

    Moderator kmessinger


    I don’t know about servers but I think it is not only permissions but who owns the server – the server or the application. But again I am way out in left field. Maybe someone will jump in here.

    Well, let’s hope so 🙂

    By the way, thank you for the tip – I tested it on another site which gave the same installation failure error, it is a solid workaround. I just wish there were a way to drill down to the heart of the matter 😛

    Especially now with automatic updates as a feature, it’s a bit uncomfortable not having a real idea of what caused this. Going over some forums, it seems I’ve not been the only one thusfar.

    I’ll keep puzzling, just in case.

    Similar problem here. I finally did a manual update, but then I’d still get the “server error” page when I went to the update page, just to check.

    Reverted to older version. Then inserted the line of code that kmessinger suggested. That worked!

    BUT, back at 3.7.1, I still cannot get to update page from admin panel. Server error. Not only that, but image upload from my desktop directly into a post is broken. I now have to upload to the media library first.

    AND, on top of THAT, when I do go through these hoops and put up a post, the next page is another server error page. The post will usually go up, but I get the error page anyway.

    is anybody else having these issues?

    Thanks. I am losing much of this day to what I had thought would be a very quick automatic update to 3.7.1.

    I’m having a similar problem. (“permission denied … Cannot update file …Installation failed.”)

    But my problem is worsened by the fact that I’m a newbie to WordPress and am clueless when it comes to code or editing. (I’ve recently converted from the now-defunct iWeb, where my ignorance was bliss.)

    Reading several forums, I understand that I need to change some code somewhere, but I’m not too embarrassed to say that I don’t know how to do that.

    Even reading WordPress’ own troubleshooting page, it appears to sound simple … Yet, here I am.

    Is there no “newbie-approved” solution for fixing this error? (Is learning to code the only way to solve problems in WordPress?)

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘3.7.1 update "Installation Failed"’ is closed to new replies.