WordPress.org

Forums

[resolved] 3.6.1 update error (24 posts)

  1. purplenaartjie
    Member
    Posted 1 year ago #

    I got the following error whilst updating to 3.6.1... Help!!!

    Fatal error: Call to undefined function wp_validate_redirect() in /home/fleursfl/public_html/wp-includes/functions.php on line 1305

    Sophie

  2. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Switch to Twenty Thirteen theme with all plugins deactivated and try again. Make sure that you have a recent backup of your site before updating.

  3. purplenaartjie
    Member
    Posted 1 year ago #

    I can't change to 1213 or deactivate plugins. Neither can I get anywhere on the website. Whatever I do now I get the same error message. There is nothing I can do within the site or my dashboard.

  4. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Use FTP or your hosting cPanel to rename the plugins folder (add -HOLD to the folder name). Similarly, rename all themes except 2013 so that your site will open using that theme. You can login after that.

  5. divydovy
    Member
    Posted 1 year ago #

    I have the same issue.

    Theme: WooThemes Function
    Plugins:

    Antispam Bee
    Features
    Google Analytics for WordPress
    Gravity Forms
    Groups
    InfiniteWP - Client
    Jetpack by WordPress.com
    jQuery Vertical Mega Menu
    The Events Calendar
    The Events Calendar PRO
    WooCommerce
    WooCommerce - Gravity Forms Product Add-Ons
    WooCommerce SagePay Form Gateway
    WooSlider
    WooThemes Updater
    WordPress Importer
    WordPress SEO

    Haven't diagnosed cause yet but thought this list might help centralise discussion. Will update once a fix/cause is located.

  6. Sunder Deep Dasna
    Member
    Posted 1 year ago #

    plugin "WooCommerce - Gravity Forms Product Add-Ons" creates problem.

    Any solutions?

  7. Krishna
    Volunteer Moderator
    Posted 1 year ago #

  8. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    @Shashank Mukherjee,
    Please start your own topic.

  9. purplenaartjie
    Member
    Posted 1 year ago #

    Thanks Krishna... I've restored from my backup and will wait and watch to see if the reported errors on 3.6.1 calm down a bit...

    Sophie

  10. jenx67
    Member
    Posted 1 year ago #

    I updated to 3.6.1 the first day they released it. I"m on my site every day, as late as last night. Now, this morning I get a message that says an update is available: 3.6.1 and I need to update now. I already updated...how could this happen? Did some gremlins get into my site for something?

  11. divydovy
    Member
    Posted 1 year ago #

    @Shashank - confirmed this plugin is causing issues for us too - seems to be overriding a core function that's now changed.

    We've opened a WooThemes ticket.

  12. Christian Wach
    Member
    Posted 1 year ago #

    @Krishna: I don't think it's helpful to paste the same response to every thread that mentions this error. People are reporting this with a wide variety of setups even when nothing else has changed. My own take on this is that the error was introduced with:

    http://core.trac.wordpress.org/changeset/25323

  13. Remi Corson
    Member
    Posted 1 year ago #

    Hi,

    version 2.4.6 of "Gravity Forms Product Add-Ons" has been released and is available from WooThemes clients account page. This new version fixes the issue with WordPress 3.6.1.

    Changelog: http://www.woothemes.com/changelogs/extensions/woocommerce-gravityforms-product-addons/changelog.txt

  14. andrespi
    Member
    Posted 1 year ago #

    Amazing time response of WooCommerce team. Congratulations!

  15. purplenaartjie
    Member
    Posted 1 year ago #

    Yep that's the one. Annoying that Woocommerce originally informed me therewas no problem yesterday. Wasted a hell of alot of my time on this...

  16. quad_cities
    Member
    Posted 1 year ago #

    I updated to 3.6.1 and can't search my Media Library. I am trying to retrieve already-uploaded images from the library to insert into a new post.

    The Search box does not respond when I type in a search term.

  17. Matt Magi
    Member
    Posted 1 year ago #

    Thanks

  18. WPyogi
    Forum Moderator
    Posted 1 year ago #

    @quad_cities - this thread is not a good place to get help - it's marked resolved. Please start your own per the forum rules:

    http://codex.wordpress.org/Forum_Welcome#Where_To_Post

    Same to anyone else who still needs help - this thread is marked resolved.

  19. wesamredsea
    Member
    Posted 1 year ago #

    The Solution is :

    By FTP change some codes .

    1. Go to wp-includes/functions.php
    search for :
    return wp_validate_redirect( $ref, false );
    replace with :
    return wp_unslash( $ref );

    2. Go to wp-includes/functions.php
    search for :
    return wp_validate_redirect( wp_unslash( $_REQUEST['_wp_original_http_referer'] ), false );
    replace with :
    return wp_unslash( $_REQUEST['_wp_original_http_referer'] );

    3. Go to wp-includes/pluggable.php
    search for :
    $location = trim( $location );
    remove this code :
    $location = trim( $location );

    Save your changes .

    Make Refresh you will see the problem was solved .

  20. wrongware
    Member
    Posted 1 year ago #

    @wesamredsea Thanks! Save my life.

  21. Christian Wach
    Member
    Posted 1 year ago #

    Just in case there are others who encounter this problem, it seems worth saying that wesamredsea's "fix" isn't a fix at all - it modifies core files (and reverses a commit) which is never a good idea since that reversion will be overwritten with the next update.

    There is usually another reason why you are seeing the error, probably a plugin which calls a function such as wp_get_referer() before it's available. The plugin should be changed so that it does not do that. See:
    http://core.trac.wordpress.org/ticket/25294

  22. purplenaartjie
    Member
    Posted 1 year ago #

    This topic is marked resolved - it was a conflict with Woothemes' plugin for Gravity Forms. Woothemes have since issued an update to the plugin to correct the conflict.

  23. jimqb4
    Member
    Posted 1 year ago #

    I don't understand most of what you are saying. I have the same problem.

  24. ymel
    Member
    Posted 1 year ago #

    Hi wesamredsea!

    I dont have those lines u mentioned under ur paragraphs 1. and 2. in my functions.php file :(

Topic Closed

This topic has been closed to new replies.

About this Topic