Support » Plugin: WordPress MU Domain Mapping » 3.6 Upgrade – Domain Mapping Error Message.

  • Resolved Kev CC

    (@kev-cc)


    Hi, I have a multisite install of WordPress, I recently ugraded to 3.6 as I like to keep up to date with the wonderful WP community.
    All my sites, domain mapped subdomains are working ok but at the top all show this message:

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/critical/public_html/wp-content/plugins/domain-mapping/domain-mapping.php on line 673 and defined in /home/critical/public_html/wp-includes/wp-db.php on line 992

    Just noticed that the same message shows up 10 or more times on the Dashboard for domain mapped sites also, but not on subdomains which have not been domain mapped.

    Any help on this would be great, I am aware that I can simply hide the error code, however I would like to find a more thorough & secure solution which may be of use to others also.

    Many thanks in advance for taking a look at this!

    Kevin

    http://wordpress.org/plugins/wordpress-mu-domain-mapping/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Ron Rennick

    (@wpmuguru)

    Go into your wp-config.php and comment out the define( 'WP_DEBUG'... line.

    This is on the list to be fixed in the next release.

    Hi Ron,
    Thanks for the reply, I tried commenting out the define( ‘WP_DEBUG’… line, however it has no effect on the error message and now I can’t access the admin area of the mapped subdomains, I have uncommented the line and still have no access to the individual admin areas, just the original error message and the dreaded white screen.
    Any ideas?

    Plugin Author Ron Rennick

    (@wpmuguru)

    Oh, I just checked in my plugins section in superadmin and it’s telling me I run the latest version.
    Is there a manual upgrade or is it a premium thing?

    Hi, I just used the superadmin to delete the plugin (in the hopes of installing the latest version) and although the plugin is showing as deleted, all the sites are still domain mapped and the install plugin’s option is still saying I have the latest version installed and therefore won’t let me install/reinstall version 0.5.4.3
    Is there something I am missing here?

    OK – most recent ‘shamefaced’ update, I regained use of my common sense, and shrugged off the foggy-headedness of the spoon fed :/ and here is how I managed to resolve the issue…

    I manually reinstalled domain_mapping.php and sunrise.php – As is clearly instructed in the installation notes and now all my domain mapped sites are no longer showing the error message and all seem to be working as before.

    I didn’t actually commented out the define( ‘WP_DEBUG’… line however it is set to FALSE, unsure if this will cause future issues?

    Anyway, thank you Mr Rennick, both for the big nudge in the right direction and for allowing me to figure out the obvious ‘square peg/square hole’ update situation myself!

    Plugin Author Ron Rennick

    (@wpmuguru)

    You’re welcome. There’s no harm in having WP_DEBUG set to false.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘3.6 Upgrade – Domain Mapping Error Message.’ is closed to new replies.