Support » Requests and Feedback » 3.6 – Please give us a way to REVERT to previous version!

  • I mean the previous version of WORDPRESS!

    I am very sorry that I upgraded.

    The footer in my themes is corrupted in 3.6, can’t add anything to it, WordPress automatically inserts more and more slashes all over the place in the existing footer, and into anything you try to type into it.

    The — used to automatically default to a dash, it doesn’t any more!

    The revisions don’t seem to be working. I worked all night on a page, it was saved and finished, I save every 5 minutes! And all of a sudden, it was GONE! And no sign of it in any of the revisions.

    And one big glitch: the html CENTER codes have a vertical space attached to them by default! Whose idea was that? If you then have to center a heading, i.e. h3, which ALSO has a default vertical space, the center plus the h3 makes a HUGE f-ing vertical space, and your title is a mile from the top edge of your post or page.

    I’m getting fed up. At least in html, when you do your page, it’s done, and it stays that way. Every time I think I have completed something in WordPress, they change WordPress, or the plugins change, and my work is all fucked up.

    I’m going back to html very very soon. The minute I finish with the current client, NO MORE WORDPRESS!

    The idiocy is killing me.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hey,

    Do not downgrade to 3.5 unless you dont have a pre-upgrade database backup and do not use 3.6 database with 3.5.x core files.

    If you have a pre-upgrade database back up, restore the database and you can download the 3.5.x from http://wordpress.org/download/release-archive/ and you can replace the core files.

    I hope that helps.
    Thanks

    Thanks for the information Anshu! I just had to revert back from 3.8 and your advice worked perfectly.

    Using an outdated version of WP is a major security risk, so that’s not really a good solution.

    Understand and agree. But my theme was not compatible with 3.8 and it broke, so it seemed like the best option for a quick fix until there is a theme upgrade. Do you have any suggestions for a better solution in this situation? I am open to ideas…

    Find a compatible theme ASAP – your site getting hacked will be a much bigger problem :)! Is the theme currently supported and maintained?

    I believe it is. I will look into it. Thanks!

    Wordfence! Get it, I bet you 3.8 has just as many security issues.. they just haven’t found them yet. You should be hardening your site. There are some great sites that explain in detail how to harden your WP install.

    Mark

    The idea that ‘outdated’ versions of WordPress are “a major security risk” is rubbish.

    Are you saying (in the semi-official capacity as a ‘Volunteer Moderator’) that until 1st August (when 3.6 replaced 3.5.2) WordPress.org was supplying a seriously flawed product? Oh, and up to 24th October when 3.7 replaced 3.6.1 … etc. etc.

    The security of sites is more about good user names, secure passwords, checking plugins for malicious code, some site hardening and a secure hosting platform.

    Just because 3.8 is out, doesn’t mean anyone can forget about security.

    The biggest decision about upgrading WordPress will always be “does it break anything” not is it (notionally) more secure.

    My solution, if anyone is interested, is to use Duplicator to copy the site onto a spare domain I maintain just for this purpose, so I can test the upgrade without breaking the site.

    If you just upgrade a site without testing, you can’t have ever worked in an IT department.

    I also maintain a ‘library’ of WordPress installations (back to 3.3.1) on another spare domain, which I can copy and implement when I need to build a site on a particular version of WordPress (using the magic of Duplicator, of course).

    The idea that ‘outdated’ versions of WordPress are “a major security risk” is rubbish.

    I’m sorry, but that’s plain wrong.

    esmi

    (@esmi)

    Forum Moderator

    The idea that ‘outdated’ versions of WordPress are “a major security risk” is rubbish.

    Where did you get that from?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    davidmcc3’s advice is incorrect.

    Older versions of WordPress have known and documented security vulnerabilities. Use them at your own risk.

    Also this post is 3 months old, and no one’s talking about reverting from 3.6 anymore, so I’m closing it.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘3.6 – Please give us a way to REVERT to previous version!’ is closed to new replies.